2

As seen on the screenshot, my MapProxy reverses Y axis and I can't figure why.

MapProxy.yaml:

services:
  demo:
  tms:
    use_grid_names: true
    # origin for /tiles service
    origin: 'nw'
  kml:
      use_grid_names: true
  wmts:
  wms:
    md:
      title: MapProxy WMS Proxy
      abstract: This is a minimal MapProxy example.

layers:
  - name: gisdb
    title: gisdb WMS
    sources: [gisdb_cache]

caches:
  gisdb_cache:
    grids: [osm_grid]
    sources: [gisdb_tms]
    disable_storage: true

sources:
  gisdb_tms:
    type: tile
    url: http://localhost:1234/styles/positron/%(z)s/%(x)s/%(y)s.png
    transparent: true

 grids:
    webmercator:
        base: GLOBAL_WEBMERCATOR
    osm_grid:
        base: GLOBAL_MERCATOR
        srs: 'EPSG:3857'
        origin: 'sw'
globals:

I've tried changing origin: to sw , nw or 'nw', but that didn't help at all. Caching is disabled. I'm using https://github.com/klokantech/tileserver-gl

wrong tile order

3

I think you need to add a grid specification to your tiles source, e.g.:

sources:
  gisdb_tms:
    type: tile
    url: http://localhost:1234/styles/positron/%(z)s/%(x)s/%(y)s.png
    transparent: true
    grid: webmercator

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.