0

I'm very new to QGIS. I want to make a shape seem seamless. As you can see on the following screenshot, there is a border on the waterarea depicted. I'd like to make this one disappear. I tried the technique explained here but it doesn't seem to work with my simple case :S

enter image description here

1
  • 2
    You can also use geoprocessing dissolve to have a unique waterbody vector file. If they are in different vector layers, merge both layers before dissolve.
    – aldo_tapia
    Jul 28 '17 at 14:59
4

Draw the outline using the same color as the fill color. Doing so will prevent gaps that can appear between the polygons.

1
  • Oh. I feel dumb right now :) I can't test now, but I think it's the right way. Thanks.
    – lvictorino
    Jul 28 '17 at 16:26
4

Changing the outline colour is useful technique for previewing, but if you want to apply certain effects (like drop shadow, shapeburst fill) the results are applied separately to each polygon, which won't look too good. Also, on some older versions of QGIS, you can still see hairline gaps.

Your best bet is to use Dissolve on your waterways layer. This will merge adjacent polygons together to a new "dissolved" layer.

Before:-

enter image description here

After:-

enter image description here

You might spot the flaw with this.. the islands have vanished. If you don't have any islands, you can probably stop here.

In OSM, river islands are sometimes overlaid on top of the river, sometimes they might be holes (interior rings) punched out of the waterway. It depends on who mapped it, and which editor they used. For rendering the OSM tiles, it doesn't matter. But for GIS, that's not enough :-) If you use QuickOSM to download waterways, it'll sometimes include these.

If this happens,

  • select all the island polygons in your waterways layer (either manually, or by looking for place=island or similar.)
  • save to a new layer "islands" (make sure to check 'just selected features')
  • then run Difference on your dissolved layer and islands layer, to remove the islands from the river.

enter image description here

You might not want shapeburst fill of course, but doing this will give you more styling options.

1
  • Perfect! Exactly what I needed. Thanks a lot Steven!
    – lvictorino
    Jul 29 '17 at 16:49
3

On your example, just click on "simple fill" then in the options, choose "No pen" in the "Outline style" option.

You just need to be aware it doesn't merge your entities, it just makes the border disappear.

No pen = no borders

2
  • Hey thanks for your answer. With this technique a very thin gap remains between the parts :( is this the only way to do?
    – lvictorino
    Jul 28 '17 at 16:10
  • You could just change the outline colour to your fill colour :)
    – gisnside
    Jul 31 '17 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.