0

I have some contour lines in a geodatabase. They are z enabled. I'm using ArcGIS Pro to create a scene and then sharing that to ArcGIS Online. I'm using the default elevation layer and have used Pro to project all contour line files to Web Mercator prior to sharing. The symbology of the lines is a simple line symbol. They look great in ArcGIS Pro:

Contours in ArcGIS Pro

They look awful and are effectively unuseable in ArcGIS online:

Contours in ArcGIS online

So far I've tried altering the line width keeping in mind desired resolution as described in the ESRI docs here.

I've had this problem previously when exporting from ArcMap to PDF and the ESRI docs mentioned something about windows graphics and that Pro should be used instead (can't find the link now). This worked for exporting to PDF. The same is not true of exporting to ArcGIS Online.

Pro doesn't seem to have any options to choose resolution or change anything much when sharing to ArcGIS online and I thought perhaps the coordinates are being rounded? Not sure but would very much like to hear any thoughts or opinion. Geonet has yielded no results so far.

Update

I've now tried sharing the map as a feature service from ArcMap. Viewing it in map viewer on ArcGIS Online the lines are fine. Viewing the same feature service in Scene Viewer in ArcGIS online the same problem exists.

I'd also be interested to know if anyone can replicate this problem.

  • It almost looks like the spatial reference is messed up. AKA the (storage) resolution is set incorrectly. Have you seen this topic? – mkennedy Aug 1 '17 at 18:13
  • Thanks mkennedy. I read through the topic. It relates to map viewer and shapefiles. This is a problem in scene viewer (the same data work fine in map viewer) and the data are stored as a hosted feature layer (orginating from a gdb). There may be some clues in the topic you posted though. I'll keep trying. – Oliver Burdekin Aug 2 '17 at 9:25
  • 1
    We are investigating this issue and will let you know what we determine. This is appears not to be pro issue but more of a feature generalization issue from the JS API side. – Russ Roberts Aug 2 '17 at 16:56
  • Thanks @RussRoberts I've also tried creating a 3d line feature in n edit session in Pro (z enabled feature class in the same GDB edited in the same scene). This seemed to render fine while the original data still did not in AGOL. However, it was not as complex as the original features (but did have some Arcs in it). – Oliver Burdekin Aug 3 '17 at 11:50
  • @RussRoberts any updates? – Oliver Burdekin Aug 9 '17 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.