0

I am trying to draw a set of arrows using the draw toolbar which point labels to certain features in my map in the layout view. I have data frame clipping set up and when I move the graphic outside of the clipping extent, it gets clipped too.

How can I omit the graphics from the data frame clipping?

  • Have you tried adding the graphics in Layout View rather than Data View? – PolyGeo Aug 1 '17 at 11:06
  • Yes it happens in both views. Also have the same issue with text. It also gets clipped to the data frame. – JamesW Aug 1 '17 at 11:09
  • Text I would expect but not graphic elements added (not just displayed) in layout view. I'm not able to test at the moment. – PolyGeo Aug 1 '17 at 11:12
  • Ok I realised the issue, I had the Focus Data Frame selected so I was in fact creating them in the data view instead of the layout view. Working fine now. – JamesW Aug 1 '17 at 11:17
  • I think you should write that up as a self-answer which is fine to do and should earn you some useful rep – PolyGeo Aug 1 '17 at 11:32
0

The issue here was that the Focus Data Frame option was selected which meant that the graphics were being created in the data view as opposed to the layout view, causing them to become clipped to the data frame along with the other data.

Once the graphics were created in the layout view the clipping was no longer being applied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.