I'm installing QGIS 1.7.4 in windows 7 & having problems with QSpatialite. I get 3 messages...

Message #1 This DB a valid SQlite DB, but not a valid SpatiaLite DB. QSpatiaLite will now try to Create a valid SpatiaLite DB

then Message #2 Error. Try to execute by yourself: SELECT InitSpatialMetadata()

then Message #3 You are using SpatiaLite V2.3 ( standart with QGIS<1.7). Please note that QspatiaLite full potential require SpatiaLite V2.4. Please update your SpatiaLite version, or move to QGIS 1.7

What I've tried

  1. Executing the SELECT InitSpatialMetadata() command from within the dialog
  2. I'm running QGIS 1.7.4
  3. The QSpatialite dialog confirms the error message because in the bottom left corner it says I'm running Spatialite V2.3.1. Thinking my problem relates Spatialite version, I ran the OSGeo4W setup again. However, the setup says I'm running spatialite 3.0.1-2 and sqlite 3.7.10-2.

The only thing I can think of is that spatialite v3 is not being picked up because the QSpatialite plugin installed v2.3.1 of spatialite somewhere. Is that possible? Any ideas?




yes, QGIS use SpatiaLite v2, so does QSpatiaLite. Therefore, QSpatiaLite is unable to manage SpatiaLite V3 DB


Qspatialite IS able to manage SpatiaLite v3 DB. You just have to ensure that QGIS is shipped with V3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.