0

I'm trying to get Mapbender3 to work with Apache2.4 and PHP5.6. I have Apache and PHP talking to each other and installed correctly. I have followed the instruction to install Mapbender3 found here: https://doc.mapbender3.org/en/book/installation/installation_windows.html

The purpose is to set up a server in order to test Geoserver and Mapbender3's abilities to talk to each other and produce a webmap.

NEW ISSUE: I go to the symphony config page. http://localhost/mapbender3/config.php I am greeted with the text below. I make the changes to the php.ini in the Apache folder and re-check the configuration. The issues don't disappear. Do I need a php.ini in the Mapbender folder as well?

This script will guide you through the basic configuration of your project. You can also do the same by editing the ‘app/config/parameters.yml’ file directly.

MAJOR PROBLEMS
Major problems have been detected and must be fixed before continuing:
date.timezone setting must be set
Set the "date.timezone" setting in php.ini* (like Europe/Paris).

RECOMMENDATIONS
Additionally, to enhance your Symfony experience, it’s recommended that you fix the following:

intl extension should be available Install and enable the intl extension (used for validators).

a PHP accelerator should be installed Install and/or enable a PHP accelerator (highly recommended).

realpath_cache_size should be at least 5M in php.ini Setting "realpath_cache_size" to e.g. "5242880" or "5M" in php.ini* may improve performance on Windows significantly in some cases.

short_open_tag should be disabled in php.ini Set short_open_tag to off in php.ini*.

PDO should have some drivers installed (currently available: none) Install PDO drivers (mandatory for Doctrine).

* To change settings, create a "php.ini".

When I go to my Apache mapbender page http://localhost/mapbender3/app.php I get a fatal error. How do I fix this?

Fatal error: 
Uncaught exception 'Exception' with message 'DateTime::__construct(): It is not safe to rely on the system's timezone settings. 
You are *required* to use the date.timezone setting or the date_default_timezone_set() function. 
In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. 
We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' 
in C:\Mapbender3\mapbender\src\Mapbender\CoreBundle\DependencyInjection\MapbenderCoreExtension.php:30 

Stack trace: 
#0 C:\Mapbender3\mapbender\src\Mapbender\CoreBundle\DependencyInjection\MapbenderCoreExtension.php(30): DateTime->__construct('now') 
#1 C:\Mapbender3\vendor\symfony\symfony\src\Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass.php(59): Mapbender\CoreBundle\DependencyInjection\MapbenderCoreExtension->load(Array, Object(Symfony\Component\DependencyInjection\ContainerBuilder)) 
#2 C:\Mapbender3\vendor\symfony\symfony\src\Symfony\C in C:\Mapbender3\mapbender\src\Mapbender\CoreBundle\DependencyInjection\MapbenderCoreExtension.php on line 30
  • What happens if you go to localhost/mapbender/config.php – Gob Tron Aug 3 '17 at 18:18
  • Not Found The requested URL /mapbender/config.php was not found on this server. – NorthLand Aug 3 '17 at 18:19
  • I mean, just replace app.php by config.php in the address you provided – Gob Tron Aug 3 '17 at 18:20
  • Oh I see. I get the Symphony Config Page. I think I can make it work from here. – NorthLand Aug 3 '17 at 18:21
  • Tell me if that helped you through your problem, or post the solution if you found it. There is not much posts about Mapbender around here, it would be nice to have the information here – Gob Tron Aug 3 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.