4

I am new to Ubuntu, so forgive me if this a very standard question: I installed QGIS 2.18 and all seems to work well. However, there is a major issue: the program uses a very strange font so I can't read anything? I tried to find something on the internet, but none seem to have the same issue.

As I do not now much about Ubuntu, my trouble-shooting-abilities are very low.

Is there a workaround to change the font in QGIS so I can get started working with it?

enter image description here

5

I see you're using LXDE. Do you have any other window managers installed which you can try? Are any other Qt based applications affected?

I suspect this is might be an issue with Qt and your window manager than QGIS specifically, so if this doesn't work you might want to try on Ask Ubuntu or SuperUser.

You could try changing the font in the settings > options menu. You could also try changing the Style option (GTK+, Mosaic, etc.).

I suspect the font is Dingbats. As this isn't readable, you can find these settings...

  • the fifth menu from the left, and
  • the second last menu item. Should see something like this.
  • you may need to use the horizontal scroll bar to see the combo box.
  • the pull down list of fonts should be readable for some (but not all) fonts.

enter image description here

Although with Dingbats it may look like ...

enter image description here

If you change the Style you'll need to restart QGIS, but font changes should take place immediately.

  • Very precise, thank you very much! I still wonder why I had Dingbats as default... Other programs than QGIS worked fine, so far (however, I didn't try that many) – yenats Aug 4 '17 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.