1

In QGIS I have a map layer which is connected to an Oracle database.

After I turn the map layer to editing mode I discover that I can only change the attribute data, create and delete objects, but I cannot move objects on the map since the move feature tool is deactivated.

Does anyone know what is the reason and is there any solution to this problem?

As shown in the picture, a few functions are deactivated in the editing toolbox even though the layer is in editing mode:

enter image description here

  • what version of qgis and oracle? – Mapperz Aug 4 '17 at 16:17
  • I have qgis version 2.18.5 and Oracle database 11g – Cliff Lau Aug 7 '17 at 6:56
  • I have the same problem. Any answer for this problem?? I am setting up an enterprise GIS database, so that all users can edit at the same time. But "move feature" is disabled if connected as user in QGIS. Im also using oracle 11g for my database. – Frank Aug 28 '18 at 7:14
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – ArMoraer Aug 28 '18 at 9:36
1

I tried to log in the map layer by using the password for the Oracle database schema where the map layer comes from then this problem does not exist anymore.

But once I use a login of any user who is granted with editing rights to this map layer then QGIS just does not allow the user to move the feature. This is very strange to me since I use the same login for the users to do the same thing in other map software and there is no problem at all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.