I have a map service enabled in my server and have kml and wms as well as mapping and feature access capabilities turned on. I can view the wms in qgis, I can veiw the kml in google earth. However when I add the map as an operational layer to my config.xml in my sample application, I get no errors, the other basemap layers come up fine, and the operational layers show up in my widget (with my layer checked on), BUT it doesn't show up. I have changed my map service document to be the same coordinate system as the layer I am trying to show. The data is coming from postgresql db as an sde service. Any help would be great

More info: I still have this problem. I have tried to add services that use different cs. I have reprojected my data to be the same as the basemap service in the flex sample app. I have tried to use a config.xml that only contained my service (and changed the xy extent to match. Still I can see it as wms and kml but not as a mapservice.


The URL for your services is incorrect. You're using the SOAP endpoint, not the REST endpoint. Try:

<layer label="Williston Pipelines" type="dynamic" visible="true"

You may also require a cross domain policy if your application and your service are hosted on different machines. Use Fiddler or a similar web tracing tool to determine if your browser is attempting to download crossdomain.xml from one of your servers; if so, supply one.

(for updated question) What do you see in the web traffic when you run Fiddler or use the Net tab in Firebug? You should see either a request to export the map, or requests to a TileHandler, or direct requests for the tiles themselves.

If images are being requested, then you can use the Inspectors tab in Fiddler to see if they really are images, or if they're just white.

If errors are being returned (404, 500, 502, ???) then those will show up right away.

| improve this answer | |

"config.xml in my sample application" I assume that your trying to add a map service to The ArcGIS Application for Flex? - Please confirm this.

How are you adding it into your config file?
Sounds like your adding it under the operationallayers tag. What have you put for the type field?


            <layer label="Boundaries" type="tiled" visible="false"
            <layer label="Fires" type="feature" visible="false" alpha="1"

Provide some more info, and it will be easier to diagnose.

  • Is your map service cached? (Check the REST endpoint to find this out).
  • What WKID is it?
  • Are the basemaps layers in the same WKID?
  • Have you set a WKID under the map tag in config.xml?
| improve this answer | |
  • Sorry I had grabbed this snippet and just forgot to paste it... <operationallayers> <layer label="Williston Pipelines" type="dynamic" visible="true" url="d1mnr3m1/ArcGIS/services/Postgres_Map/MapServer"> – Brad Nesom Oct 13 '10 at 13:57
  • I have tried this with dynamic, tiled, and feature types. I did read a post about turning off the cache in IIS is that where I need to look? I am a noob so not sure where the REST endpoint is. I assume WKID is the crs. The data not showing is in nd83-nf the basemaps are not, I believe they are in aux merc web. So that has been one of my headscratchers as to how it all works. do I have to reproject all the data I want to use in a sample app like this using arcgisonline? Thanks for the help – Brad Nesom Oct 13 '10 at 14:18
  • I thought I could set the mxd that I am using to publish the map service to nd83-nf – Brad Nesom Oct 13 '10 at 14:26
  • Sounds like ur in a bit of a muddle. Ill get back to you later on. For now, familiarise yourself with this: help.arcgis.com/en/webapps/flexviewer/help/index.html And watch this: training.esri.com/acb2000/showdetl.cfm?did=6&Product_id=983 Cache nothing to do with IIS, but your map services. REST directory is : http://<hostname>/arcgis/rest/services – Simon Oct 14 '10 at 1:26

Well I hate to answer my own question, but about an hour after I posted the bounty, it started working. After reprojecting my data to the same crs as the basemap layer (from arcgisonline) all is well. I did have to overcome some security issues (including a non-working ms firewall). I am now on the rabbit trail to find out how to use my data in it's normal crs. I assume that I need to define the wkid tag for my config.xml. This was a costly question!

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.