2

I am trying to use SAGA from within QGIS.

I can run SAGA standalone, but not from within QGIS - nothing appears in the Processing Toolbox.

I tried following Why is SAGA from the Processing Plugin not recognised? and updating the path, however I cannot update the path. If I change it, it simply reverts to what it used to be. I've tried closing and reopening QGIS but that does nothing.

I'm also not sure what I should be pointing to - is it the SAGA app? Something else? I can't seem to point to the App directly, as I cannot navigate to the folder where it is. If I move the app - it breaks.

I've found a few old instructions online, but no luck following them. I'd prefer not having to move things back and forth between QGIS and SAGA if I don't have to.

I possibly (probably) have multiple versions of saga on my computer, as I've tried following many different sets of instructions for how to get this working.

QGIS version 2.14 SAGA version 2.31 Mac OS X version 10.12.16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.