1

I have just downloaded and installed Google Earth Pro, and I cannot get place names to show up at all.

Can you suggest a course of action?

  • Can you confirm that in the Layers panel (bottom left), the boxes next to "Borders and Labels" and "Places" are both checked on? Then, do place icons show up when you zoom in to the town/block level? Many place markers will only show the label on the map when you hover over them with your mouse cursor. – Christiaan Adams Aug 7 '17 at 22:44
  • Hi Christiaan. Thank you for getting back to me so quickly. Yes, both of those are on, but nothing is showing up. This problem has only arisen since I installed the new 'Pro' version. I am not sure how it is better than the previous version, and I may prefer to go back to that, if it is possible and this problem cannot be fixed. – Lewis Evans Aug 9 '17 at 0:42
  • Lewis, can you see the built-in data on the map, like country borders, city names, etc? Or is all that blank? Alternatively, is the issue that you're no longer seeing makers for places that you put on the map yourself, either via KML files that you loaded or things you drew yourself? There have been some recent issues with the data in "My Places" disappearing during the upgrade... if that's what happened, then I can hopefully help you get that data back. – Christiaan Adams Aug 10 '17 at 5:34
  • Hi Christiaan. This is very weird. I left Google Earth open for an hour while I did something else, and gradually all the information turned up. So, I tried it again this morning and it did the same thing. It's just incredibly slow to turn up. I don't know what could cause that. – Lewis Evans Aug 10 '17 at 16:14
  • Strange indeed. Glad the data is showing, but being super slow to load is unusual. Maybe try clearing your memory and disk caches in Google Earth? Those are under Tools > Options (Windows) or Google Earth > Preferences (Mac), then the Cache tab. – Christiaan Adams Aug 11 '17 at 16:42
0

I had the same problem....finally fixed it. Right click on name of tour. Under properties, uncheck box near the top labeled, "Show contents as options (radio button selection). Click "OK". Now the box to the left of the tour destinations may be checked (or unchecked) that will show or hide the names of ALL the tour points.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.