3

I'm working in AutoCAD with a layer from a shapefile.

The problem occurs when Autocad opens the file : the coordinates are the same than in QGIS, but when I try to draw a line 1 meter is 0,00001 in autocad.

I do not know how to get it in a workable scale. I saw similar questions, and tried to apply the solutions shown (modify CRS,...), but them didn't work. I am working with a coordinate system (WGS84)

0

4 Answers 4

3

You are working in a system that uses angular units (i.e EPSG 4326 WGS84 Lat long system). One meter must be around 0,00001°, that's why you have so small values in Autocad.

You need to put your shapefile data "flat" in a meter unit projection within QGIS (for example to your local projection or UTM zone) by saving as and choosing the right projection. Depending on your location, we can help you choose one. Then you just need to export from QGIS in DXF.

Export DXF

2

Autocad use cartesian coordinates. Export in UTM or your local system cartesian.

2

AutoCAD use cartesian coordinates? No my friend, sorry - only AutoCAD Civil 3D use this. So, what you can to do is convert the file to a UTM or local system by using AutoCAD Civil 3D.

(In Settings) File name > Edit drawing settings> Categories...

1
  • AutoCAD ever use cartesian coordinates: relative or absolute x, y, z. AutoCAD Civil suport CRS Commented Aug 19, 2017 at 13:52
1

The simple answer is that you need to export the geometry in the correct projection for your needs. If you're using meters then you need to use a projected CRS that uses meters as its unit (i.e. UTM...). If you're using FT then you need to use a projected CRS that uses FT as the unit — and naturally a CRS that is in the vicinity of your data.

In QGIS I would recommend setting the PROJECT CRS to the projection you need and use Project -> Import/Export -> Export project to DXF

then be sure only the layer(s) you need is(are) checked. And most importantly that the correct CRS is chosen (it should be the project CRS). Symbology can be tricky as you need to define a good scale but straight geometry — that is, the geometry data and not the QGIS generated symbology — is transferred without issue. If you're exporting MText be warned that it is hardcoded and can't be easily manipulated once in CAD. A workaround for this is a simple edit (find and replace) of the ASCII DXF before importing into CAD.

When importing into CAD (I usually insert it as a block) you need to be sure that your drawing is based on either unspecified units or either Meters or Feet — not millimeters or inches! Then when you insert it define its insertion point as 0,0. It will then lay in the cartesian plane (yes, it is cartesian) relative to the CRS's origin, which will be CAD's world origin. And that means that it could be very, very far away from CAD's world origin. Zoom to extents to find it and then leave it where it is to work on it.

This method makes the back and forth between CAD and QGIS relatively painless.

NOTE: I've had issues using a Layer's [right click] "Save As..." for the DXF operation but never using the project export. All other Layer "Save As..." functions seem to work well for CAD (i.e. clipping a raster for a CAD underlay — make sure the correct CRS is chosen!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.