2

I'm trying to create an action in QGIS that open this link

htt p://www.gulliver.it/itinerario-foto/14451/#!/uploaded/2014/large/20140929123749.jpg||grid2

but the character | is converted into %7C preventing the page beeing open correctly, in Chrome, indeed the result of the action [% "web-link field" %] is:

htt p://www.gulliver.it/itinerario-foto/14451/#!/uploaded/2014/large/20140929123749.jpg%7C%7Cgrid2

I defined action as you can see in the picture qggis actions' definitions

Here there are the webpages as they appear in my browser: enter image description here Rewriting the link in the field and the action like: [% "truncated web-link field" %]||grid2 is the same.

How is it possible to make the page open correctly?


Alternatively I could open the webpage internally but, following this instructions

ht tps://docs.qgis.org/2.2/en/docs/training_manual/create_vector_data/actions.html#hard-fa-open-a-webpage-directly-in-qgis ,

I haven't any results (nothing happens clicking on elements).

Any solutions?

  • 1
    i tried your links (both links) and everything is running fine here ... using qgis 2.18.7 ... don't u forget something ? Can u show us how u defined the action (screen capture ?) – snaileater Aug 12 '17 at 8:03
  • To enable the actions u have to have both the "action button" and the right layer selected ... did u check that ? – snaileater Aug 12 '17 at 8:18
  • The first and the second actions badly work, because I don't get the webpage-link properly, but in the browser address bar it appears the link ending with "...%7C%7Cgrid2", which doesn't return the original layout, in my chrome browser – Sandra Aug 12 '17 at 8:26
  • So the action is working a bit then ? u said "nothing happens when clicking on elements" ... r u sure of the url construction and r u sure of the grid2 parameter ? When i try your url i have a grid of pictures indeed .... – snaileater Aug 12 '17 at 8:38
  • The first and the second actions badly work, the third not at all. – Sandra Aug 12 '17 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.