19

I have been trying to teach myself QGIS by using this forum and others to help. Most of my questions can be answered by downloading plugins that are available through 3rd party repositories but for some reason I am not able to connect with these. Anyone have any ideas why this is the case?

  • In Qgis, Plugins>Fetch Python Plugins, click the Repositories tab. What is the "Status" that you see there for existing repositories? – vinayan May 10 '12 at 12:17
  • On the Respositories tab the status is 'unavailable'. Clicking 'Add 3rd party repositories' makes no difference. – BNA May 10 '12 at 12:32
  • 1
    are you behind a proxy? I do get that error while i am... – vinayan May 10 '12 at 12:34
  • i work in the NHS so probably... – BNA May 10 '12 at 13:22
  • Please use a Comment rather than an Answer for a comment like this. However, if you were going to detail some steps you took in order to answer your own Question then that would be acceptable as an Answer which you could then Accept to finalise the question. – PolyGeo May 29 '13 at 2:34
21

I was able to set up proxy settings in QGIS (Settings->Options->Network) so that it could communicate through our proxy server. In my case, the Default proxy type didn't work--I had to use HTTPProxy. Once that was done, I had no problem getting to the plugins on the repo servers.

  • I am behind a firewall and Hawken answer worked for me...Thanks – user9122 Jul 26 '12 at 6:10
  • also need restart Qgis. Thx) – lolipop Apr 6 '17 at 11:57
8

Here is a workaround if you are behind proxy and not getting the repositories. This would work for all python plugins.

  1. Download the plugin directly from the repository url using your browser. For example, for CadTools, download the zip file from the here repo link
  2. Unzip the file. Copy the folder(usually one directory down the extracted folder) to your python plugins directory. In windows, this would be C:\Program Files\Quantum GIS Wroclaw\apps\qgis\python\plugins
  3. Restart Qgis and now you can see this plugin installed. Just enable this plugin in the Plugin Manager.
  • 1
    And in OSX the directory is ~/.qgis/python/plugins – Simbamangu May 10 '12 at 20:34
  • In vinayan's step #1, you can access the repository urls, by double-clicking on a listed repository and copy/pasting its .xml url to your browser. Many of the repositories have a .xsl stylesheet that renders the plugin listings as HTML. For example: faunalia.it/qgis/plugins.xml If the repository does not have a stylesheet, have a look at the .xml source in your browser for the download links. – dakcarto May 11 '12 at 0:00
  • Update for QGIS 2.0 and later: the target path is C:\Users\username\.qgis2\python\plugins, and the repository is now plugins.qgis.org/plugins – AndreJ Jan 8 '15 at 10:50
  • For QGIS 3 it will be: C:\Users\username\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins – HeikkiVesanto Jan 19 '18 at 9:39
2

If you are running QGIS from behind some firewall/proxy setups, you can't get the repositories. I have the same issue when running QGIS behind a restrictive firewall via a proxy at work, but no problem when running QGIS from home.

  • You can get the repos! See my answer for more details. Basically a restart is required. – Unapiedra Jan 19 '18 at 9:23
  • This is perhaps a change since I posted this answer almost six years ago. – MappaGnosis Jan 19 '18 at 10:46
1

Running QGIS 2.18.12.

  • Configure the Proxy in Settings > Options > Network. (As others have pointed out.)
  • Select Use proxy for web access.
  • (For me):
    Proxy type: HttpProxy
    Host: my-proxy-url.foo (No leading https://)
    Port: 3128.
    User/Password: empty.
  • Verify that it works: Help > Check QGIS Version.
  • Restart QGIS.
  • Now, go to Plugins > Manage and Install Plugins.
  • Success: Plugin repository gets updated.
1

On your QGIS go to

settings >> options >>network

Then check the "Use proxy for web access" box

set the proxy type to be defaultProxy to use the system proxy

That way, whatever proxy seetings you have will be inherited and you won't have to insert again.

0

I had the same issue with not being able to connect to official repository but found how to fix this. I replaced DHCP with a static IP address and QGIS now connects to repository. How to here: https://www.howtogeek.com/howto/19249/how-to-assign-a-static-ip-address-in-xp-vista-or-windows-7/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.