3

I'm very new to QGIS, and this is baffling me. I used "split vector layers" to create new layers in QGIS, and have been trying to export the file to dxf. However, when I open my new dxf files, every feature is on its own layer, and my new layers are empty. I used "export to dxf" on mac yosemite.

  • In what format are your input data? – Paulo Martinho Aug 14 '17 at 7:27
  • I've had the same issue and curiously enough, it only started with more recent versions of QGIS (I think it worked properly with 2.14.x?) I've had this issue with QGIS virtual layers, spatialite layers, shapefiles, csvs, spreadsheets, although they will label the layers differently depending on what is the "main attribute". For example one of my point layers was exported with one layer per point ID (134, 134A, 135..), yet a separate polygon layer was grouped according to size (so layer 5 had all the 5m-wide buffers, etc.) – she_weeds Aug 15 '17 at 2:55
2

This is an issue I had in QGIS 2.18.12, I can agree with @she_weeds, that it worked properly in 2.14.x. I started a bug report on this (https://issues.qgis.org/issues/17126), and in 2.18.14 it's now fixed (just tested). It should not depend on the format of your input data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.