0

I have made a large map of a province and shown every house and streets as, lines and polygons, when label all of them and exporting as PDF, the text is not showing properly and it has like sharp edges, i have converted the labels to annotation, created an annotation group for it and set diffrent refrence scales for annotation group, also have tried all and every single option in pdf exporting menu, but still the problem is not solving.

closed as off-topic by Midavalo Oct 20 '17 at 0:28

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Midavalo
If this question can be reworded to fit the rules in the help center, please edit the question.

2

You may have transparency enabled, or be using a picture marker symbol, on one (or more) of your features. Your transparent layers will rasterize anything below them in the TOC. Use the following script in the Python window to identify rasterizing layers:

import arcpy

def DetectRasterization():
  mxd = arcpy.mapping.MapDocument("CURRENT")
  df_list = arcpy.mapping.ListDataFrames(mxd)
  foundRasterization = False
  noneFoundMsg = "No rasterizing layers were detected."
  for df in df_list:
    lyr_list = arcpy.mapping.ListLayers(mxd, data_frame=df)
    for lyr in lyr_list:
      if lyr.isRasterizingLayer or lyr.supports("BRIGHTNESS"):
        foundRasterization = True
        if lyr.isGroupLayer and lyr.transparency > 0:
          print "In data frame '" + df.name + "', the group layer '" + \
                   lyr.longName + "' is a rasterizing layer:\r",
          print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                "\tTransparency is " + str(lyr.transparency) + " percent.\n"
        elif not lyr.isGroupLayer:
          print "In data frame '" + df.name + "', the layer '" + \
                   lyr.longName + "' is a rasterizing layer:\r",
          if lyr.transparency > 0:
            print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                  "\tTransparency is " + str(lyr.transparency) + " percent.\n"
          else:
            print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                  "\tTransparency is 0 percent, but the layer may be a\n" + \
                  "\traster layer or contain rasterizing symbology such\n" + \
                  "\tas bitmap picture symbols.\n"
      del lyr
    del lyr_list
    del df
  if not foundRasterization:
    print noneFoundMsg
  del df_list
  del mxd

DetectRasterization()
  • Thanks dear cl3, the problem was with text style, solved. – Suhrab Nasery Aug 18 '17 at 8:01
0

My assumption is that your issue is not actually a problem with your labels and text but how the file is being exported. Several things to try are listed below:

Increase the output resolution. See: How To: Modify output resolution (dpi) for ArcMap printing or exporting

Increase the Output Image Quality (OIQ) setting. See: How To: Use the Output Image Quality option.

Reorder the map elements and layers to have layers containing picture fill, picture marker, or transparent symbols at the lowest possible order in the Table Of Contents.

Replace the Picture Fill symbols with simpler, vector fills.

Replace the Picture Marker symbols with font-based vector marker symbols.

Remove transparency. For exported maps, transparency can be re-applied to the desired elements in an external editing application, such as Adobe Illustrator.

From: This ESRI Tech Support Article

If this is occuring on someone else's machine when they open your pdf, try the below solution:

When you export to PDF, on the second tab of the "Options" you will see a box that will most likely be unchecked: "Embed All Document Fonts" Make sure that it is checked and it should reduce those errors for the people viewing your PDFs -- (From this q&a)

Another thing to try is to export as TIFF and see what it looks like from there. If it's correct, then you can convert the image to pdf using Adobe.

  • Thanks dear MaryBeth, actually the problem was with picture filled text style which was rastarizing, it required a very high resolution(more than 5000dpi) to draw it, so i have changed the style to simple text and the problem is solved. – Suhrab Nasery Aug 18 '17 at 8:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.