1

In ArcGIS Desktop 10.4 I have a NetCDF-File from this source http://eca.knmi.nl/download/ensembles/downloadchunks.php (grid 0.25, years 1995-2016), and am trying to add it to a Mosaic Dataset I already created. The data consists of temperature over time (in days).

I tried two variations:

  • reading the .nc-file as raster, saving as layer-file and then adding the layer-file to the Mosaic Dataset by the "add rasters to Mosaic Dataset"-tool.

  • reading the .nc file directly into the Mosaic Dataset using the "add rasters to Mosaic Dataset"-tool. Here I also ticked the variable I need (tg).

Both Variations gave the same result: the features are drawn, but the numbers are wrong. Don't know, where they are coming from, but it's obviously not taking the variable I ticked.

Does anyone have an idea what I did wrong?

  • Did you read it (in the first approach) using the Make NetCDF Raster Layer tool from the Multidimension Tools toolbox? That should have allowed you to specify a variable as well. – J Kelly Aug 17 '17 at 1:23
  • Yes, that's how I made the rasterlayer. The rasterlayer on itself works fine, I exported it as a layerfile, and imported that file, and that fine as well. But adding it to the mosaic dataset makes strawberry-mash. On a second try I just dragged and dropped the .nc file into ArcMap, that makes something that looks fine as well, and did all the above procedures with it - same result. I need all of the analysis by this evening, or the scientists around me have a problem... – BettinaS Aug 17 '17 at 8:03
  • And that raster layer does have the right values (in other words the variable you set in the dialog was the right one)? I know this sounds entirely superstitious, but try Copy Raster on the raster layer (not the layer file). Possibly the output of Copy will interact better with the mosaic. – J Kelly Aug 17 '17 at 13:29
  • Yes, the rasterlayer does have the right values, it works fine, as long as I don't try to add it to a mosaic laser. Not sure, what you mean by copying the rasterlayer. If I copy and paste the layer inside a running ArcMap it will have only an internal representation, and I'd have to save it as a layerfile again, in order to then add it to a mosaic layer. You can't add a raster to a mosaic layer that only exists inside ArcMap... – BettinaS Aug 18 '17 at 21:31
  • No, there is a tool called Copy Raster that makes real output, and the output is a Raster Dataset (at least when stored in a gdb). – J Kelly Aug 18 '17 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.