0

I have point data (about 1000 points) in a .mdb. One of the columns within the database is "State", and when I ran the "Split by Attribute" tool by state the new returned records were correctly split by state.

I then added a new column to the database, "Sample_Year" in which every point was assigned either 'Year 1', 'Year 2', 'Year 3', 'Year 4', or 'Year 5'. When I ran the 'Split by Attribute' tool to split the points by "Sample_Year", 5 records were returned, correctly named ("Year 1', "Year 2...) but the attribute table for each record was empty and no points were actually plotted on my map.

Any ideas on what might be causing the empty return?

I believe I'm using the tool correctly as the first time I tried it with an existing column it worked correctly. I've tried it on other existing columns since, and those all work too. It's just this new column that I've created that returns empty attribute tables and no data.

I'm new to ArcGIS.

1

After adding the new field, try creating a new feature layer from the existing layer.Then attempt your 'Split By Attribute' anaysis. My second suggestion is to remove spaces, instead of having 'Year 1', have 'Year1'. The tool may be capturing only the first text in your field.

  • Just tried creating a new feature layer from the existing layer and running the tool from that. Same result though, empty attribute tables were returned. I also tried switching years to just 1, 2, 3, 4 or 5 and it didn't seem to make a difference. Thanks for your ideas – Kactus Aug 17 '17 at 19:47
0

Did you have any features selected at the time of running the 'Split by attributes' tool? If so, try deselecting all and then running the tool again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.