I have 4 shapefiles in total, and for 3 of my attributes tables, I was able to directly copy it (including the formatting) into Excel. I do this by using 'Select All' and 'Copy Selected'. When I went to copy my last table, which has 57 features, it copied, but it loses its formatting when pasted (it became one long line to text) into Excel. I'm pasting into a new spreadsheet for every table and they're all point shapefiles. Does anyone know why sometime copy and pasting keeps the formatting while other times it does not?

I'm running ArcMap 10.3 and using Excel 2010.

  • Simply drag relevant dbf file into Excel
    – FelixIP
    Commented Aug 19, 2017 at 1:52

2 Answers 2


The 'Select All' and 'Copy Selected' method is often unreliable with +2000 records as it sometimes won't copy more data. (Depends on how much memory you have and if ArcMap is in a good mood.)

You can also open up the table for a feature class > click the options in the top left hand corner > "Export..." > Change the file type on to dBase table witch excel can open or pick ".txt" and just switch the ending to ".csv" works as well.


Not sure why the formatting would be different between the similar shapefiles, but I would recommend using Table to Excel for such workflows:

ArcGIS http://desktop.arcgis.com/en/arcmap/10.3/tools/conversion-toolbox/table-to-excel.htm

ArcGIS Pro http://pro.arcgis.com/en/pro-app/tool-reference/conversion/table-to-excel.htm

  • 1
    Thanks for responding! I ended up running an export to get the my data, but I was just really curious to know why that happened. It just seems odd that it'll work for one but the other.
    – user103999
    Commented Aug 18, 2017 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.