I have coordinates in WGS 84 34N and I am trying to add the points to ArcGIS 10.2. This should be no problem as I have done it many times but I cannot figure our why it is not working now. The excel file looks like this

In the Add XY data window I choose the coordinate system WGS 84 34N and an event layer is created. I cannot see the points even if I select a row in the table and click "Zoom to". It zooms to a certain extent which is not correct. There is no point visible in the middle.

What am I doing wrong? I have tried to swap X and Y but it doesn't help. I used an online converter in order to check manually that my coordinates really are located there where they should be, and it is fine.

  • What happens if you Right-click on your event layer and select "Zoom to Layer"? – Midavalo Aug 18 '17 at 17:51
  • 3
    Open up the attribute table of the xy event layer and make sure the values are importing correctly. Also start a new ArcMap session, import the data and see if they look correct. Try setting the display units to decimal degrees too. It might be a localization issue with the commas as decimal places. – mkennedy Aug 18 '17 at 17:57
  • Are you saving this file as a CSV file before importing into ArcGIS? If so, try removing the commas from the number values and try again. – GBG Aug 18 '17 at 18:59
  • Thanks for the replies. Zoom to layer zooms to about the same place than "Zoom To" for one of the rows in the table. I saved it as xlsx but now tried also csv (without commas). Doesn't help. I set display units to decimal degrees and it doesn't help. I really cannot understand what is wrong as I have done this successfully dozens of times before. – JanneL Aug 19 '17 at 9:11
  • The values also look fine in the table. – JanneL Aug 19 '17 at 9:17

You should check your dataframe coordinate system and make sure it is set as EPSG:32634 coordinate system prior to inserting your data. Sometimes, when it's not set correctly, ArcGIS tends to lose the data and one cannot zoom in.

Check also the attribute table. If there's no data, it might be something to do with the way data is read. For example, some ArcGIS version don't like the latest version of Excel files. In that case, try saving as Excel format .XLS and not .XLSX Your CSV file may not have been read, so you might have to check the way it is created.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.