1

I want to write the results of processing a Rinex file using geodetic heights, and an external geoid from Spain's geographic institute IGN.

I have downloaded the geoid files from their FTP in text format from ftp://ftp.geodesia.ign.es/geoide/ascii/ with .txt and .asc extensions, and in binary GRD format (ftp://ftp.geodesia.ign.es/geoide/GRD/EGM08_REDNAP.grd), but none of them seems to work, and I am getting the exact same results as with RNX2RTKP default's geoid (EGM96, 1ºx1º), while I would expect to see a significant difference in height.

In order to tell RTKLIB that I want to use the external geoid, I run the program as follows:

rnx2rtkp.e -p 0 -k config_file.conf rinex_file.obs brdc_orbits.obs -o output_file.sol

where config_file.conf has only de following lines:

out-height         =geodetic
file-geoidfile     =geoid_filename

and geoid_filename is the .asc, .txt or .grd file.

What am I doing wrong? Am I not providing the file in the correct format, or should I set something else in the config file?

1

You are missing the out_geoid option. My working file looks like:

...
out-height         =geodetic   # (0:ellipsoidal,1:geodetic)
out-geoid          =egm96      #(0:internal,1:egm96,2:egm08_2.5,3:egm08_1,4:gsi2000)
...
file-geoidfile     =Z:\Users\drf\Work\RTKLIB\JUNK\WW15MGH.DAC
...

If you look at the RTKLIB manual, it identifies the geoid as internal, or four specific GEOIDs. I think other files would need to match one of these formats:

I cannot tell if EGM08-REDNAP geoid is equivalent to a subset of the EGM2008 1"x1" file above or not. If you have a regional/local geoid model, I don't think RTKLIB will parse it, you might be better off solving for an ellipsoidal heights and then converting to your datum externally. Or maybe you could patch it into a copy of the global egm08_1 file and use that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.