I am in the UK and my QGIS projects are based on UK Ordnance Survey mapping data and are set up in EPSG:27700. Whenever I have tried dropping an OpenLayers layer (Google Satellite/Bing Maps Aerial) in via the OpenLayers plugin (v0.90) it is always offset by 10 metres or so from my mapping data (rendering it useless).

I have tried turning on 'on the fly' reprojection, reprojecting in Google Mercator (EPSG:900913), starting a new QGIS project in Google Mercator projection, etc etc but the result is always the same.

I don't suppose anyone can describe a workflow that would result in a QGIS project containing an OpenLayers layer correctly aligned with (UK Ordnance Survey) mapping data?

(Apologies if this is the wrong place to post this type of query but I am inclined to think it is a case of me being stupid rather than a bug in the software.)


Update... The problem appears to be with QGIS, as an export of a correctly georeferenced vector map to KML as suggested by nhopton below also results in a misalignment with the satellite imagery.

  • 1
    need some test data, even just some points.
    – Willy
    May 12, 2012 at 8:48
  • Can you let us have details of your system, QGIS version and so on? Regarding the shift that you are getting, is this more like six or seven metres? If your data is vectors, do you find the same shift if you export it to KML and view it in Google Earth?
    – nhopton
    May 13, 2012 at 9:15
  • QGIS info: QGIS version: 1.8.0-Lisboa; QGIS code revision d1cb3f3; Compiled against Qt 4.7.1; Running against Qt 4.7.1; Compiled against GDAL/OGR 1.9.0; Running against GDAL/OGR 1.9.0; GEOS Version 3.2.2; PostgreSQL Client Version 8.3.10; SpatiaLite Version 3.0.1; QWT Version 5.2.1; The mapping reference base I am trying to overlay with the satellite/aerial imagery from OpenLayers is in raster format (TIFF with TFW) and is correctly georeferenced. It is an Ordnance Survey 1:10000 scale 5x5km raster tile if that means anything to anyone...
    – Will
    May 15, 2012 at 16:21
  • P.S. I have installed several builds of QGIS over the last couple of weeks and have had the same problem with all of them. The shift is definitely in excess of 6 to 7 metres. I can't really supply any test data for copyright reasons - I'm not attempting anything complicated though, just overlaying a raster map with an OpenLayers layer.
    – Will
    May 15, 2012 at 16:28
  • probably related: gis.stackexchange.com/questions/3895/…
    – underdark
    May 31, 2012 at 14:26

2 Answers 2


If you have a shift of a few metres, you should try using a nadgrid instead of the constant +towgs84 parameters as defined by EPSG:27700. The three-parameter transformation used only has a accuracy of 21m.

You can find the official grid data here: http://www.ordnancesurvey.co.uk/oswebsite/gps/osnetfreeservices/furtherinfo/ostn02_ntv2.html

An alternative solution would be


with an accuracy of 2 metres.

See also:

Raster incorrectly reprojected to OSGB(27700)

How to reproject a raster file in QGIS with datum transformation?

  • Thanks for reviving this question Andre- I had given up on the possibility of using the OpenLayers plugin in QGIS but your alternative solution with the revised +towgs84 parameters means that it now works just fine for my needs.
    – Will
    Jan 7, 2013 at 15:30


On-the-fly-projection is on and default CRS is 27700. Also, if I can visualise these layers correctly overlayed in ArcGIS, I would expect it to be the same in QGIS. DOn't get me wrong. QGIS is great and I'm trying to get my colleagues to use it. I've read a few post here on stackexchange but also elsewhere and it appears to be related to some problem that has been introduced in 1.8. People seem to suggest that it was working in 1.7 but I just can't work out how I'm meant to solve this problem.

Cheers Antonio

  • The problem introduced with QGIS 1.8.0 ist that conversion from OSGB36 to WGS84 was changed from 7-parameter Helmert (defined by +datum=OSGB36) to 3-parameter Helmert (defined by +towgs84=x,y,z,0,0,0) loosing accuracy. Latest build of GDAL was changed back to a 7-parameter Helmert (with no zeros). I'm not sure if QGIS Master nightly builds have this already implemented. What you can do is install QGIS 1.7.4 on a different computer, search for srs.db, and replace the version you find in QGIS 1.8.0 with the older one. Make sure to make a safety copy before...
    – AndreJ
    Feb 9, 2013 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.