1

User details first: OSX 10.11.6 using QGIS 2.18.9 with kyngchaos GDAL 2.1.3 and all other standard frameworks, dependencies, and plugins (e.g., MrSID).

I want to merge five high-res .jp2 files using QGIS via Raster > Misc > Merge, but after several attempts lasting several hours, the tool appears to make no progress whatsoever. (The longest attempt was over five hours with no other user processes.) There doesn't appear to be any activity on Activity Monitor either. I've tried merging all five files at once, and I've tried merging just two, but I get the same results. However, if I call gdal_merge.py from Terminal or iTerm, the tool works as expected -- aside from the fact the image is flipped. Using Raster > Misc > Information works as expected.

I re-installed all dependencies, frameworks, plugins, and QGIS itself, and I've altered the paths incorrectly set by SQLite (this response), and I've matched the paths in the QGIS advanced settings editor, and still the process is interminable. I know there are alternatives within QGIS to Raster > Misc > Merge, but why is this method interminable while calling it from Terminal works?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.