3

I have a French Postcode map which looks fine on screen. It's CRS is EPSG 2154 - RFG93/Lambert 93. Pretty much any French shapefile when added looks like it's leaning back suggesting to me, I'm no expert in this area, that the projection is wrong. I can see both views for each layer when I use zoom to layer on the layer in question but they are never together.

I have tried set layer and specifying the Lambert CRS and save it and open it. Still the same!

I also have a French Gazetteer text file which has lat/long. When I import that - same problem. Seems to revert to a CRS/projection/thingy that means it's leant back in the picture, and I can't see it on my main map.

Have had same issue with UK data so it's something I am doing wrong rather than the data.

Where am I going wrong?

Using QGIS Las Palmas

  • 4
    Have you enabled on the fly projection in the QGIS settings? Also, if you export to a new layer you can set the output CRS. – mixedbredie Aug 23 '17 at 19:48
2

You seem to have forgotten to tick a box (Enable on the fly transformation"). Have a look below.

For the aspect you mention, your project or your data might be in EPSG:4326 (WGS84), which would explain the compressed aspect... Have a look below to have an idea.

EPSG:4326

EPSG4326

EPSG:2154

EPSG2154

Check project properties in the Project menu and check if you have the same as me.

project properties

  • Hi Gisnside, Thanks for taking the trouble to help me out. – Andrew Whittam Aug 24 '17 at 9:10
  • .. The OTF box was ticked. Both in project properties and in the bottom left of the QGIS window. Am trying to paste screenshot so you can see. I have fiddled with all the projection/CRS options I can see but still have 1 layer in the odd format and French Postcode polys in the correct format. – Andrew Whittam Aug 24 '17 at 9:13
  • For projection problems, you can do it another way : untick the Enable on the fly. Clic on a layer + zoom in. Write down the coordinates. Do the same on the other layer. Write down the coordinates. Check if the coordinates are in the "normal" range of the data. WGS84 should be around 40 to 50 in Y coordinates whereas Lambert 93 should be around 6,000,000 in Y coordinates – gisnside Aug 24 '17 at 10:18
  • The French Postcode polys show 6,000,0000 and the rubbish one shows 2.22, 40.65 in it's middle of France. I assuming the rubbish layer is therefore WGS84... Again tried to change to the Lambert one, pressed Apply. Then checked again and it says selected... Lambert. Am confused.. where can I be going wrong??? Tx! – Andrew Whittam Aug 24 '17 at 18:15
  • I'm sure it's nothing enormous. Define your rubbish layer in WGS84 (EPSG:4326), défine the postcode one as L93 (EPSG:2154) in the respective layer properties (right click on the layer/properties/General). Then go in the projet menu, choose properties/CRS and define EPSG:2154 as the project projection and recheck the enable on the fly projection. What happens next ? – gisnside Aug 25 '17 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.