4

I am trying to take an excel file, display xy data, export, and then project. When using the VTDeerCulverts excel file (field names listed in pdf below) the process works until I project the data. At this point the data appears when I identify points but when I try to display the attribute table the following message appears.

enter image description here

After this happened I tried to edit the field names again, as you can see in VDCulvUp (field names listed in pdf below) However when I did this, the problem appeared when I would export the data to a shapefile. At this point the table is empty, no points or data, even though it displays just fine prior when displaying xy data.

PDF of Field Names for Excel Files

Any ideas on a solution?

  • Which GIS software are you using? – whyzar Aug 28 '17 at 14:32
  • The columns name longtitude and latitude. Did you also set wgs 84 (epsg 4326) as the crs? If you set another crs the coordinates might be outside of the boundaries and therefore not loaded. – Matte Aug 28 '17 at 15:05
  • Yes, in GIS and using WGS 84 - seems to have been a problem in the field name. Can't use quotation marks. – OC Chitayat Aug 28 '17 at 15:12
3

Based on the dialog box, it looks like you're using ArcMap. The error message indicates that ArcMap is interpreting at least one field to have a quotation mark (Depth_6"). Try removing the quote, if you haven't done so already.

For complex tables, I sometimes have better luck converting my MS Excel worksheets to comma separated values files (.csv) before adding to ArcMap.

  • Yes, I am in ArcMap. And I just redid the process according to your suggestion of removing the " symbol and it worked beautifully. Thank you for the suggestion! – OC Chitayat Aug 28 '17 at 15:04
  • 1
    Adding to this - when importing excel data I will always open the file and clear all the formatting and save as a csv before bringing it into arc. – jbalk Aug 29 '17 at 4:52
1

There appears to be an issue with your data source as well as the solutions are mentioned in your error message.

You should troubleshoot based in the order it is listed

In addition, check these:

  1. Are you able to open your excel data in excel? If not, then the issue lies therein.
  2. Field names can always be an issue when loading data, however from the looks of the PDF print out, the field names appear to be fine.
  3. Are you able to view the file in the TOC in ArcMap?
  • Yes, it is viewed in arcmap and loads fine in excel. I was just able to fix the problem another suggestion. It appears " cannot be included in field names. Thanks for your input! – OC Chitayat Aug 28 '17 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.