1

Relatively new to QGIS. Trying to add an attribute from a polygon to all the points in a shapefile (about 800 points) that are within that polygon. Used "join attributes by location", point layer as the target layer, polygon layer as the join layer. I ran it and after about 20% was processed, it stopped and I received the following error:

TypeError: QgsFeature.setGeometry(QgsGeometry): argument 1 has unexpected type 'NoneType' 

Looking for some troubleshooting tips on how to identify what is tripping me up here.

  • Hi, welcome to GIS SE. What have you tried? Can you share us your code or data to reproduce the problem? A feature seems to have invalid geometry – aldo_tapia Aug 30 '17 at 21:38
2

Looks like you've got some null geometries in the table. Try running the "Remove null geometries" algorithm on your table before running the Join by Attributes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.