6

Recently started using QGIS 2.18, for basic mapping. I am using Swedish GEO-agancy data shapefiles as bottom layers with my own shapefiles as toplayers (EPSG:3006 (SWEREF99 TM)), including a GPX file (EPSG:4326 (WGS84)) manipulated by GPXeditor.

When using the Print Composer to export the map as a GeoTIFF I can not choose a "Reference Map" under "Composition -> Export Settings".

So the exported TIF does not include any georeferencing when opening it in ex. Avenza on my phone. Also the map on my phone is already 2/3 zoomed in, I can't see an overview by zooming out. I can zoom in though.

All coordinates match up in the QGIS project window with the EPSG:3006 system, even the GPX waypoints that are Google Maps system coordinated EPSG:4326 (WGS84).enter image description here

Why can't I set a Reference Map ? Is it because all layers are EPSG3006 exept the GPX waypoints that are EPSG:4326?

Or is there some other reasone the map does not export a GeoTIFF.

  • As far as I remember, the dropdown box of Referenzkarte is only filled if you have more than one map in your print composition. – AndreJ Aug 31 '17 at 11:38
  • Yes that is logical :) But then the one map I have should be defaulted in the dropdown menu when no other is available. – odlmag Aug 31 '17 at 11:58
  • I think it's a bug issues.qgis.org/issues/16796 – pigreco Aug 31 '17 at 13:02
  • If you export the map canvas from Project > Save As Image you get a geo-referenced image output. If you export from Composer using Composer > Save As Image you get a non geo-referenced image unless you check the option to Save World File under Export settings. And the empty reference map dropdown is still blank in 2.18.12 even with more than one map in the composer. – mixedbredie Aug 31 '17 at 13:13
  • how could you set a reference map with out a second map to refer to? see qgistutorials.com/en/docs/making_a_map.html – Ian Turton Aug 31 '17 at 17:03
3

If you export the map canvas from Project > Save As Image you get a geo-referenced image output.

If you export from Composer using Composer > Save As Image you get a non geo-referenced image unless you check the option to Save World File under Export settings. However, I cannot get QGIS 2.18.12 (Windows 7 x64) to write a world file with Composer output. This has been reported before in QGIS 2.16 (https://issues.qgis.org/issues/15268) and was fixed but this may be a regression in 2.18. It might work in QGIS on Linux or OSX.

[aside: the empty reference map dropdown is still blank in my 2.18.12 even with more than one map in the composer.]

enter image description here

See the docs here and here for more info on how to set this up.

  • Ok thanks for the info! Was hoping for a solution to the Composer way of doing this as i can control the resolution output... Will wait for the fix! – odlmag Sep 1 '17 at 10:37
  • So actually when I export from the Project Window, my TIF file is not Geo-Referenced. Within the file itself. When importing it to Avenza Maps on my phone it warns med that the map has no reference. It does however export a TFW file. Which Avenza cant handle. So I understand now that my export from the Composer has a reference, but the coordinates are all wrong compared to the ones in the Project window where i am working. Strange... – odlmag Sep 1 '17 at 10:59
  • And, thankfully, this will all be fixed in the next point release as Nyall said. – mixedbredie Sep 1 '17 at 11:03
2

This was bug https://issues.qgis.org/issues/16924, which will be fixed in the next point release (2.18.13).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.