5

I have a Geoserver running with multiple accounts (secured via Geofence). Each account has access to a certain workspace. In Qgis I am able to add data from any account using the WMS service.

The problem arises with Arcgis, where I can make a connection to Geoserver but the layers are not added. Using Wireshark to check the outgoing request I've noticed that ArcGIS does not include a basic authentication header, and is therefore unable to show the layers.

  • My Geoserver service security rules are: Rule Path: * . * , Roles: *
  • Role(s) are associated with the required user and those Roles are linked with the correct workspace/layers in Data Security.

What I've already tried is adding username and password in the URL like: http://user:pasword@urltogeoserver.com/geoserver/wms?, with no succes.

How can I add a secured WMS layer through ArcGIS? Or how can I force ArcGIS to include a basic authentication header in the request?

  • 1
    "10.x" is a whole series of products covering much of the last decade, some of which have been retired. Please Edit the question to specify what exact version(s) you tested, and the URL of the instruction 'the Catalog Security needs to be set to Challenge'. – Vince Sep 1 '17 at 10:09
  • When you create the server connection in catalog it should prompt you for the credentials to use when accessing the server.... – NULL.Dude Sep 1 '17 at 15:50
  • 1
    That the behavior I would expect, however it does not prompt for a password. You can send a Getcapabilities request without a password and it will successfully connect to the server, however the layers are password protected and thus no layers are shown. In Qgis, this is as simple as just filling in a username and password in the connection dialog, but this option does not seem to be available in ArcGIS – cf2 Sep 4 '17 at 7:23
2

This appears to be an issue that has been around for quite a while. For example, GeoNet has Error when trying to add secured WMS layers to the map.

Posting it at GeoNet which is Esri's forum does not appear to have resulted in an answer above, and GIS SE is not a formal support site so this is one that I think you should take up Esri via its formal Support if you think that it is a bug or ArcGIS Ideas if you think it represents and enhancement request.

0

This problem seemed to resolve for me once the line

mode=hide

was added into the layers.properties file.

This wasn't in there initially nor was any other mode selection. I only came across it by accident when I changed back and forth between mode selections to test functionality and it appeared all of a sudden.

If I hadn't have been reading the file and trying to manually edit it I wouldn't have noticed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.