0

enter image description hereI loaded a shapefile and I know it has different classes and subclasses. One can also see in the attribute-table. But on the screen it is only one layer and I cannot make out any option to make the different classes visible and to work with the single classes. I once had this problem already but I sadly can´t remember how I solved it.

  • 1
    I would suggest adding the attribute table and or classes/subclass you refer too. – whyzar Sep 5 '17 at 13:27
3

Not sure if you layer/attribute table has the classification field/values within it or not. If so, follow the steps below to style the data based off the field/class values:

  1. Right click layer and select Properties
  2. Select Style tab, and from the top drop down select the Categorized option, under the Column drop pick the field that has the class/values, click the Classify button, and finally change the symbol and value if needed
| improve this answer | |
1

there are two options depending on your aim

  1. If you only want to style the different classes, you have to choose the style as categorize and the column which classifies the data (for example myclassor ìd`as in my image)

enter image description here

  1. If you want to make any further spatial manipulations, I would suggest splitting the layer into the different classes.

    • Select the different classes inside the attribute table with

      "my_class" = 'my_value'
      
    • Save the selection as a new file with right click on layer -> "save as.." and then tick the save only selected feauters.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.