1

I have a point layer and a line layer coming from PostGIS. Points represent sensors (two for each side of the road), lines are GPS tracks. I need to move the sensor locations towards the lines. As I cannot take the closest track in each case, I decided to do it manually because I only have around 100 sensors.

That's easy to handle in QGIS, right? But to my surprise, I'm struggeling to activate snapping when moving points. I've enabled snapping for the corresponding layers and I can see that it would work when creating new features but not for moving them. According to this source, I should use the node tool. While it's possible to snap two points with each others they still not land on the track. Are there any other options I missed?

  • Please add a screenshot of your snapping options – underdark Sep 5 '17 at 17:00
  • I choose "To vertex and segment" for both layers with 10 pixel tolerance (like in your screenie on twitter). As said, everything works fine when I want to add features. I can see the snapping preview, but for moving or node tool there is no snap preview. Anyway, I've already found out that I was going in the wrong direction with this approach. So I do not need the question to be resolved. Still, would be nice to know how it would work. – Felix Kunde Sep 5 '17 at 18:42
2

I've tried this with Shapefiles and it works great. There is a snapping preview when using the node tool.

enter image description here

  • Those were also my settings, but it did not work for my two PostGIS layers. So, I've tried it again with a fresh project with only these two layers and it works. Don't know what the issue was. Maybe to much data to index in my project? (~10GB) – Felix Kunde Sep 6 '17 at 18:18
  • @FelixKunde If that's the case, using advanced settings (where it's possible to specify the behavior for each layer separately) should help – underdark Sep 7 '17 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.