1

I have a set of 1000 urban points that I'm trying to intersect with a classification result to find the accuracy but I keep getting an error "GEOS geoprocessing error: One or more input features have invalid geometry."

1

Double check your feature table to make sure that all of features have geometry/shape data associated with them.

To help with this you may want to download the Geometry Checker Plugin.

And also check this GISSE Question for other options

If all features appear valid, have you tried resetting the CRS?

From this Q&A:

Reset the CRS. Go to Settings>Project Properties> CRS and Set a Reference system again. This should do the job. If not, export it as an ESRI shapefile.

  • All the features are valid, and yes I tried resetting the CRS and it didn't work, but I tried on a different version of qgis and it worked fine, I don't know the reason though. I was using QGIS 2.18.11 then the one that worked is qgis 2.8.2 – Bara'a Sep 6 '17 at 15:53
  • Early versions of QGIS 2.18 had a whole suite of bugs related to invalid geometry error showing up despite geometry being completely valid. Your issue sounds like a similar bug, which you can report here: issues.qgis.org/projects/qgis/issues – csk Sep 14 '17 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.