1

I have worked with .shp, geodatabases and WMS formats in QGIS but I am new to working with WFS format. I have QGIS 2.18 installed on my computer.

I am trying to open and view U.S. NOAA NHC WFSserver, http://idpgis.ncep.noaa.gov/arcgis/services/NWS_Forecasts_Guidance_Warnings/NHC_Atl_trop_cyclones/MapServer/WFSServer, in QGIS. Actually I get the connection to work, I can add the layers I want to Layers Panel, I can view the attribute table and if I do a 'zoom to layer' the screen moves to approximate location of where I expect to see the data layer. I just cannot see the actual features on the map.

I am not sure what the issue is? Has anyone worked with this data series before.

Screenshot of QGIS canvas

  • 1
    Over the last couple of days, NHC has been timing out here and there or slowly loading. Assume that the traffic to that site has been pretty heavy. – MaryBeth Sep 6 '17 at 15:31
2

I'm afraid this is another broken WFS service. If you look at the output it is sending then (e.g. https://idpgis.ncep.noaa.gov/arcgis/services/NWS_Forecasts_Guidance_Warnings/NHC_Atl_trop_cyclones/MapServer/WFSServer?request=getfeature&service=wfs&typename=AT1_Past_Points) you'll see that it isn't encoding the shape element.

<wfs:member>
<NHC_Atl_trop_cyclones:AT1_Past_Points gml:id="AT1_Past_Points.1808">
<NHC_Atl_trop_cyclones:stormname>GENESIS023</NHC_Atl_trop_cyclones:stormname>
<NHC_Atl_trop_cyclones:dtg>2017082718</NHC_Atl_trop_cyclones:dtg>
<NHC_Atl_trop_cyclones:year>2017</NHC_Atl_trop_cyclones:year>
<NHC_Atl_trop_cyclones:month>08</NHC_Atl_trop_cyclones:month>
<NHC_Atl_trop_cyclones:day>27</NHC_Atl_trop_cyclones:day>
<NHC_Atl_trop_cyclones:hhmm>1800</NHC_Atl_trop_cyclones:hhmm>
<NHC_Atl_trop_cyclones:tau>0.0</NHC_Atl_trop_cyclones:tau>
<NHC_Atl_trop_cyclones:mslp>0</NHC_Atl_trop_cyclones:mslp>
<NHC_Atl_trop_cyclones:basin>al</NHC_Atl_trop_cyclones:basin>
<NHC_Atl_trop_cyclones:stormnum>11</NHC_Atl_trop_cyclones:stormnum>
<NHC_Atl_trop_cyclones:stormtype>DB</NHC_Atl_trop_cyclones:stormtype>
<NHC_Atl_trop_cyclones:intensity>25</NHC_Atl_trop_cyclones:intensity>
<NHC_Atl_trop_cyclones:ss>0</NHC_Atl_trop_cyclones:ss>
<NHC_Atl_trop_cyclones:lat>11.5</NHC_Atl_trop_cyclones:lat>
<NHC_Atl_trop_cyclones:lon>-16</NHC_Atl_trop_cyclones:lon>
<NHC_Atl_trop_cyclones:shape/>
<NHC_Atl_trop_cyclones:idp_source>al112017</NHC_Atl_trop_cyclones:idp_source>
<NHC_Atl_trop_cyclones:idp_subset>AT1</NHC_Atl_trop_cyclones:idp_subset>
<NHC_Atl_trop_cyclones:idp_filedate>1899-12-30T00:00:00</NHC_Atl_trop_cyclones:idp_filedate>
<NHC_Atl_trop_cyclones:idp_ingestdate>1899-12-30T00:00:00</NHC_Atl_trop_cyclones:idp_ingestdate>
<NHC_Atl_trop_cyclones:idp_current_forecast>9/6/2017 2:55:26 PM</NHC_Atl_trop_cyclones:idp_current_forecast>
<NHC_Atl_trop_cyclones:idp_time_series>9/6/2017 2:55:30 PM</NHC_Atl_trop_cyclones:idp_time_series>
<NHC_Atl_trop_cyclones:idp_issueddate xsi:nil="true"/>
<NHC_Atl_trop_cyclones:idp_validtime xsi:nil="true"/>
<NHC_Atl_trop_cyclones:idp_validendtime>2017-09-06T12:01:01</NHC_Atl_trop_cyclones:idp_validendtime>
<NHC_Atl_trop_cyclones:idp_fcst_hour>8/27/2017 6:00:00 PM</NHC_Atl_trop_cyclones:idp_fcst_hour>
<NHC_Atl_trop_cyclones:nhc_wallet_id xsi:nil="true"/>
<NHC_Atl_trop_cyclones:nhc_active_storm>0</NHC_Atl_trop_cyclones:nhc_active_storm>
<NHC_Atl_trop_cyclones:nhc_xml_wallet xsi:nil="true"/>
</NHC_Atl_trop_cyclones:AT1_Past_Points>
</wfs:member>

The get capabilities claims support for other formats but when I tried GEOJSON I get a 400 error from the server. While CSV did work but isn't very helpful. KML also worked but didn't include any geography so again not a lot of help.

You'll need to dig around and try to find out who runs the service and suggest they switch to a working WFS like GeoServer or MapServer which will work and are free. Sadly they didn't fill their name in the capabilities document, probably out of shame.

  • the NOAA is probably busy trying to handle the immense amount of traffic they are getting right now. we just got over a major in houston, and there are three more active storms. just some food for thought. – annag Sep 6 '17 at 15:41
  • I second the MapServer, you can use this url and load it with "Add ArcGis MapServer Layer" idpgis.ncep.noaa.gov/arcgis/rest/services/… – HDunn Sep 6 '17 at 15:42
  • 1
    I'd also guess this is the reason. When doing a "Zoom to feature" from the attribute table in QGIS, it plots the message "Zoom to feature id failed: Feature does not have a geometry" for several layers. – tareq Sep 6 '17 at 15:44
  • 1
    Shame that isn't a standard – Ian Turton Sep 6 '17 at 18:09
  • 1
    It is hard to say if the service is broken or not. The DescribeFeatureType idpgis.ncep.noaa.gov/arcgis/services/… says that none of the attributes is compulsory, including the geometry attribute. The data itself seem to contain lat and lon. WFS without geometry is valid by the standard but naturally normal GIS clients can't place such features on the map. – user30184 Sep 6 '17 at 18:14
1

the NHC just sent out a tweet and posted a message to the main website http://www.nhc.noaa.gov stating that they are experiencing higher than normal traffic and to please be patient with delays.

  • 1
    it's just broken not timing out – Ian Turton Sep 6 '17 at 15:41
0

I think the problem is that the service advertises a default coordinate reference system as:

<wfs:DefaultCRS>urn:ogc:def:crs:EPSG::0</wfs:DefaultCRS>

and QGIS doesn't know how to handle this projection, because it doesn't exist.

In other words the service is misconfigured.

  • that is yet another issue and may explain why it isn't encoding the geometries – Ian Turton Sep 6 '17 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.