1

I have an .mxd that is using absolute pathnames. I want to change this property to use relative pathnames but the option is disabled, grayed out, when I go to the .mxd properties. It is actually grayed out every every .mxd I try. How do I enable this option?

enter image description here

Edit

At @kenbuja suggestion I checked the option "Make relative paths the default for new map documents" in Arcmap options. Then I was able to get new .mxds to use relative paths but the option was still disabled in the mxd properties. Also I need to try to get this working about 20 existing .mxds.

enter image description here

  • Are you accessing the MXD via a server ? – whyzar Sep 6 '17 at 17:11
  • I also notice that you don't have a button next to the Default Geodatabase path that allows you to change it. – kenbuja Sep 6 '17 at 17:16
  • @whyzar no the .mxds are on my local drives. – Dowlers Sep 6 '17 at 17:25
  • @kenbuja The only way i know of to change the default database is through the Catalog window in ArcMap which I have done. I set the Home folder to the folder the mxd is in and I set the default geodatabase to a FGDB in the same folder. – Dowlers Sep 6 '17 at 17:27
  • Try putting your mxd in some other place maybe ? – gisnside Sep 6 '17 at 17:36
2

Since I can't add an image to a comment, this is in response to @Dowlers comment in the original question. Your dialog is missing the option to change the default geodatabase, which is available in all the mxds I have opened.

enter image description here

In the ArcMap Options dialog (found in the Customize menu), do you have to option to make relative paths the default?

enter image description here

  • Thats odd I don't see it. Also my thumbnail buttons are disabled. What version of ArcMap are you using? – Dowlers Sep 6 '17 at 17:35
  • This is using 10.5.1, but it shows up in 10.4.1 and 10.2.2, two other versions I just checked. – kenbuja Sep 6 '17 at 17:42
  • I did not have this option turned on. I turned it on but the option is still disabled in the .mxd properties. However I found I could get the option checked on (but still disabled) when I created a new .mxd. I then set the home folder and default geodatabase. I added data to the .mxd and saved it. I then copied the entire folder to a new location and opened the .mxd. It now contained the relative data and the Pathnames property is checked but disabled. I'll update the question with this info. – Dowlers Sep 6 '17 at 17:48
2

Turns out I was accessing the .mxd properties from the wrong location. I was right clicking the .mxd in ArcCatalog and choosing properties from there. The correct way of doing it is to open the .mxd itself and get to the properties by choosing File>Map Document Properties.Once I did this I could change the options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.