0

I'm making a map package to use it later in a WPF application, I shared the layers as a map package and there is no problem but when I tried to open the map package file again I found that all the layers have the red exclamation mark which means that the link to the data is broken, I fixed it and set the data source then re shared again but the problem persist.

Here are the pics of the situation:

First before sharing the map package everything is good First before sharing the map package everything is good

Opening the map package file I found the link is broken Opening the map package file I found the link is broken

Here when I tried to share it again before fixing the data source to see what error will result Here when I tried to share it again before fixing the data source to see what error will result

1

I think that you just need to ensure that you are using relative paths in the map document that you package.

From the Setting map document properties help:

You can define how path references are maintained in your document by checking or unchecking Store relative pathnames to data source. If this box is checked, paths are stored as incomplete paths that are relative to the current location of this document on disk. Using relative paths makes the map document more easily portable because ArcGIS will resolve the paths to the document's data sources relative to the document's current location in the file system rather than by full paths that include a drive letter or machine name.

Using relative paths doesn't mean that the layers in your document will never need repairing. Even with relative paths, it is still possible for a document to be unable to find its data sources if the document or the data sources are moved to a different location relative to each other, such as to a different part of the folder hierarchy or to a different disk.

  • Well that worked when I unchecked the Reference data Option in the "Share as Map package dialog". But also I noticed a strange thing when I tried to re share it but in another location with everything the same as my first trial it worked with no problems, what I suspect was the problem is that the first path contains Arabic characters unlike the other path. – Ahmed Elsayed Sep 7 '17 at 4:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.