2

If I start a project and want to use qgis2web: Nothing happens, I see only the hourglass. Then I must restart qgis.

If I start only qgis and then start qgis2web, after click to "leaflet" I get an error message:

qgis2web produced an error:

Traceback (most recent call last):
File "C:/Users/juko/.qgis2/python/plugins\qgis2web\maindialog.py", line 318, in previewMap
preview_file = self.createPreview()
File "C:/Users/juko/.qgis2/python/plugins\qgis2web\maindialog.py", line 280, in createPreview
dest_folder=utils.tempFolder()).index_file
File "C:/Users/juko/.qgis2/python/plugins\qgis2web\leafletWriter.py", line 98, in write
folder=dest_folder)
File "C:/Users/juko/.qgis2/python/plugins\qgis2web\leafletWriter.py", line 296, in writeLeaflet
if cluster[count]:
UnboundLocalError: local variable 'count' referenced before assignment

I tried to delete and reinstall the plugin with the qgis installer: same error. I tried to find a solution within the forum, but it is difficult as a not-programmer for me to see, if some of the error-solutions could help me.

Any idea? QGIS under Windows 10

1

You are correct that starting qgis2web with no layers open in QGIS results in an error message. I didn't know that, and it needs to be fixed. However, it should work when you have layers loaded. If you are experiencing problems with layers loaded in QGIS, you probably need to upload your project and layer files so others can try to recreate the problem. Also, for possible bugs in software, this is probably not the best place to ask - try logging an issue at qgis2web's Github repo at https://github.com/tomchadwin/qgis2web/.

UPDATE: The error message issue is now fixed in the master branch of qgis2web on Github. Please test if you can, and report back in replies to the issue I've opened relating to this bug: https://github.com/tomchadwin/qgis2web/issues/538

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.