4

I am having problem using the Delete column (Batch processing) under Vector Table tools. I do not understand what the Field to delete column means. I have tried using any of my layer's attribute column header names (like FLAG or NOTE) but it just keeps giving the error message:

Wrong or missing parameter value:Deleted column (row1)

QGIS Delete columns (Batch processing)

My attribute table for that layer has a value of NULL for the FLAG column. I plan on using batch processing as I have several similar layers. How can I get the batch processing to delete that column?

3

Your flag is okay. The error message says Deleted column is missing.

Slightly scroll to the right-hand side. You will find ellipsis [...] button.

Click on this three-dots button and give a Shapefile name for the new layer. It will be created without the column you have set to Field to delete.

3
  • Thank you very much. It works now. Is there a possible alternative to "Delete columns"? I was thinking of using "Refactor fields" in batch instead because my understanding is that it could delete several columns at once. The problem is that the "Fields mapping" column of Refactor fields Batch Processing doesn't recognize 'flag' like Delete columns does. – JAT86 Sep 9 '17 at 14:04
  • @JAT86 I am glad it worked out. I am also interested in the issue with "Refactor fields", which I cannot replicate. Can you post it as new question perhaps? Thanks! – Kazuhito Sep 9 '17 at 23:18
  • Thank you for the response. I have posted the new question. Kindly check: gis.stackexchange.com/questions/254843/… – JAT86 Sep 10 '17 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.