2

I have several layers and want to delete some of their table attributes columns, like FLAG. Using Refactor fields is fine:

Refactor fields

However, when I do it in batch, I get an error in the Fields mapping column which doesn't recognize FLAG:

Missing parameter value: Fields mapping (row 1)

Fields mapping error

I was hoping to use the tool in batch as I have several columns I want to have deleted in many of my layers.

  • @mgri This question by JAT86 was the first. Please see below answer and comment by gisinside, who later posted new question focusing on the syntax. – Kazuhito Sep 10 '17 at 15:12
  • 1
    @mgri I posted the question you point out to be able to answer specifically to this one : I was sure it was a syntax problem, but couldn't find the right way of writing it. thanks for your detailed answer by the way. I'll update mine below to answer JAT later when I have a bit of time to try it :) – gisnside Sep 11 '17 at 8:48
2

It doesn't answer the question, but as a simple answer to your real need, I suggest you'd rather use the Delete Column Tool in Batch mode :

Delete batch

For your question, I think your syntax of the "field mapping" box is not correct. Field are often with double quotes "FLAG" for example. To delete a column, just don't include it in the field mapping and it won't appear in the generated layer.

(I'm looking for the syntax of the field mapping field but I haven't found an answer yet. I'll update here when I find)

Not the answer you're looking for? Browse other questions tagged or ask your own question.