1

My CRS is US national Atlas Equal Area | EPSG:2163

First, I right-clicked on my layer, opened the Attribute Table, toggled editing mode, then opened the Field Calculator.

Next, I checked the box for Create a new field, put in "area_calc" for the Output field name, then chose $area as the value.

However, the problem I'm having is that the area calculation values don't really make sense (I think). For example, the value for area of Alabama on Wikipedia is 135,765 km^2, and the area_calc value is 13. All fields in this column are extremely low compared to the actual state area values.

My question is:

1) If the CRS units is in meters, why are the area values so low?

NOTE: When I use Vector -> Geometry -> Export/add Geometry Columns, the results are the same.

  • Are you able to post a screen shot of your CRS, attribute table? Also, any other layers in your document? – whyzar Sep 11 '17 at 13:48
  • Does the layer for which you are calculating areas have an assigned projected coordinate system? Area calculations are often inaccurate if the input layer is not projected. – Marie Holler Sep 11 '17 at 13:52
  • What value do you set in the length of the new field and in precision just below the field type when you use the field calculator? You need at least an integer field with a length of minimum 12 for a calculation in m² with $area... – YoLecomte Sep 11 '17 at 14:32
  • I think you should correct your CRS assignment from gis.stackexchange.com/questions/254763/… first. – AndreJ Sep 11 '17 at 14:52
1

For area calculations to come out right you need to either save your file in the National Atlas Projection or make sure you have an ellipsoid set under Project -> Project Properties -> General -> Measurements (as @andreaJ points out).

Here I have two states files one in 4326 and the other in 2163 with OTF projection set to 2163. In both cases I calculated the area in square km as $area / 1000000 and set it as the label.

enter image description here

2163 shapefile

As you can see the figures are pretty close in.

  • 2
    It depends whether you have selected an ellipsoid or None/Planimetric under Project -> Project Properties -> General -> Measurements. EPSG:2163 uses a sphere. – AndreJ Sep 11 '17 at 14:56
  • so it does, I had never noticed that setting before – Ian Turton Sep 11 '17 at 15:16
  • @AndreJ Do I have to have the ellipsoid set as well or is it just one or the other? – NaN Sep 11 '17 at 18:25
  • If you set the right ellipsoid, your measurement gets closer to the official value. – AndreJ Sep 12 '17 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.