2

I´m trying to upload geoTIFF files to GeoNode 2.6.3, installed in Ubuntu 16.04. When I try I get this error:

Could not save the layer layer_name, there was an upload error: Error while storing uploaded file::Unable to create /usr/share/geoserver/data/data/geonode/layer_name

It used to work in GeoNode 2.4, and the geoTIFF files I´m uploading are the same ones I had in 2.4 version. I tried the upload from the web portal interface and from the QGis plugin "Geoserver-explorer". Had same error in both cases. What could be the problem?

edit: add parts of geoserver.log

2017-10-19 15:26:19,059 ERROR [geoserver.rest] - No such datastore: geonode,landsatcr_3_re8_58
2017-10-19 15:26:19,060 ERROR [geoserver.rest] - 
org.geoserver.rest.RestletException

2017-10-19 15:26:19,078 ERROR [geoserver.rest] - No such coverage store: geonode,landsatcr_3_re8_58
2017-10-19 15:26:19,078 ERROR [geoserver.rest] - 
org.geoserver.rest.RestletException

2017-10-19 15:26:19,096 ERROR [geoserver.rest] - No such wms store: geonode,landsatcr_3_re8_58
2017-10-19 15:26:19,096 ERROR [geoserver.rest] - 
org.geoserver.rest.RestletException
  • Did you see the geoserver log for more details about this error? – geoA Oct 19 '17 at 18:23
  • I edited the question adding fragment s of geoserver.log – AN For Oct 19 '17 at 19:50
1

I solved it. It was a misconfiguration in the GeoNode REST role service. This link helped me find the error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.