0

I have an ArcGIS feature service that contains 18 layers. For some reason, when I query 2 of the layers through my JS web app, it prompts for additional authentication (similar to logging in to REST service directory).

All layers are referencing feature classes in the same SDE database using the same database connection authentication.

I am trying to prevent my users from having to authenticate twice (once when first hitting the feature service, and again when querying one of the two odd layers). Seems to be some odd auth error. (We are using Integrated Windows Authentication)

0

MXD and Layer cache

Finally solved it. Here was my solution:

  • Start with new fresh MXD
  • Add all layers to MXD manually (do not copy layers from original MXD)
  • Republish, overwriting existing service

The issue seemed to exist with my MXD. I suspect that there may have been a previous database connection lingering behind the scenes. Clearing cache and resourcing/re-adding my 2 problem layers did not resolve. But starting with a fresh MXD worked, and my redundant authentication prompt is gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.