4

My laptop is Windows 10 and I have installed QGIS 2.14 64bit twice; because due to some problems I uninstalled the software and reinstalled it. Now: "qgis has stopped running when startup"

I have searched for solutions on GIS SE and here is what I have done:

  1. I delete the .qgis2 but it fails;
  2. I tried to run qgis-ltr-bin.bat as "gis.stackexchange.com" guides but it fails;
  3. I tried to uninstall and delete everything about QGIS in C: drive as "gis.stackexchange.com" guides but it fails;
  4. I tried to install other software like 2.18 64bit but it also fails.
  • did you install the standalone installer or the network-installer befor you tried to install and reinstall? – Kurt Sep 11 '17 at 18:31
  • I had the same problem with QGis 2.18 64bit on windows 8. In my case it solved installing windows updates, and then reinstall. Particulary c++ was outdated. – geoA Sep 11 '17 at 19:33
  • it is a standalone installer,and i still can't solve the problem now. – Orlanto Ji Sep 11 '17 at 20:12
3

I would recommend installing using OSGEO4W Network Installer, which is a package manager for open source GIS software. It gives your more visibility of the installation process and more flexibility to work out what may be going wrong. See What is OSGeo4W?

QGIS, like many open source GIS applications uses other open source components as part of its environment. These can all be bundled up in a standalone version from http://www.qgis.org/en/site/forusers/download.html. However there is another method using the OSGEO4W Network Installer, also available from the same download page.

As I understand it, OSGeo4W is an umbrella installation package that allows the compatible version of components to be installed within the same installation environment. It gives better visibility of what is installed, and allows individual components to be updated if need be.

As you have researched, if there is an old version of QGIS uninstall this first in the usual way, and it is important to delete the folder C:Users/Program Files/QGIS

Download OSGeo4W from http://www.qgis.org/en/site/forusers/download.html

enter image description here

Run the executable file and choose ‘Advanced install’ on the first window, then progress through the windows until the ‘Select Packages’ options.

You can check for any latent components on your system by opening each category one at a time and check that each line shows “Skip” next to the package.

enter image description here

This will show that GIS components have been successfully uninstalled. They will probably all be showing skip, unless you have other open source GIS software on your system. If you do and you don't want them click on skip until it changes to uninstall, or if you do want to keep it leave it as skip, or perhaps install the latest version?

In Desktop category click on Skip on the line qgi-ltr: QGIS Desktop (long term release) - To add the latest LTR

enter image description here

Or Skip on the line qgis: QGIS Desktop for the latest release

enter image description here

You can choose to install other components, or other GIS software for example if you use ECW files, like I do in my work, then you will need to open the category Libs and click on Skip on the line gdal-ecw: ECW Raster Plugin for GDAL. (ECW is a non-open source component, and this plugin is not installed as standard through the OSGeo4W installation.)

If you are unsure I would recommend keeping it simple and just installing QGIS for now and come back and install other components as you need them, and as you run through the installation one of the screens is to install Unmet Dependencies which are packages required by QGIS, but not selected. So you don't need to worry about working out what other components you need as OSGeo4W does this for you automatically.

  • tried as you said by OSGEO4W Network Installer to install QGIS long term version2.14.18.but the problem still remain unsolved. I have use alternative way from my collegue by startup without any plugins by add --noplugins in line "start "QGIS" /B "%OSGEO4W_ROOT%"\bin\qgis-ltr-bin.exe --noplugins %*" in file of "C:\Program Files\QGIS 2.14\bin\qgis-ltr ". The problem still remain unsolved. – Orlanto Ji Sep 12 '17 at 16:11
  • What was the first problem that caused you to uninstall and reinstall? – Martin Hügi Sep 12 '17 at 16:12
  • I have installed QGIS long term version 2.14.18,but somehow it has stopped running for some unknown reason. – Orlanto Ji Sep 13 '17 at 5:24
  • Have you checked as that your Windows Updates are up to date as @geoA commented? – Martin Hügi Sep 13 '17 at 7:37
  • checked and updated ,but unsolved. – Orlanto Ji Sep 13 '17 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.