I am trying to create a hillshade. I am using the DEM terrain model tool, choosing the right input file and write output, but keep getting this error message "ERROR 1: Band data type Byte not supported in GMT, giving up.". What does it mean? Is there a plug-in that I have missed to install or am I writing something wrong?

  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. – YoLecomte Sep 12 '17 at 18:53
  • I've deleted the second question, please post it in a separate thread – underdark Sep 12 '17 at 19:06
  • What file type have you chosen for output? Maybe include a screenshot of the tool's dialogue in your question. – AndreJ Sep 13 '17 at 5:42

I'm guessing from the error you’re attempting to write out a GMT-compatible netCDF. According to the documentation (emphasis mine)

Newly created files (with a type of GMT) will always have units of "meters" for x, y and z but the x_range, y_range and z_range should be correct. Note that netCDF does not have an unsigned byte data type, so 8bit rasters will generally need to be converted to Int16 for export to GMT.

That suggests you need to use the -ot option with something like Int16.

  • 1
    Thanks! The problem could be solved by manually editing "-of GMT" in the text area in the dialog box to "-of GTiff" – Linn Sep 13 '17 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.