1

I'm using a complex styling for a points layer in QGIS, including two markers and a Geometry generator to set up a line between points and labels (see style description in this post).

The result is that either in the Layers Panel and within a legend created with the map composer, the layer has no representation (no icon at all!).

Layers Panel (see either obs_tri and site_tri layers) :

enter image description here

Map composer's legend :

enter image description here

Is this a bug or is there a way to get a nice legend all the same?

  • 18 months on... has this changed? Is there any way to get (at least somewhat) automatic legend entries if doing more complicated symbol styles? – Flyto Jun 26 at 21:26
3

Geometry generator symbology tends not to show up properly on the legend, especially if you use map units and more complex combinations of symbologies. Sometimes in the Layers panel the symbology will take up massive amounts of space and still remain blank.

To get useful legends, I either manually edit the composed map in an image editor (if it's a once-off) or create a duplicate set of the problematic layers, and use conventional equivalents of the symbol (i.e. without geometry generator, or at a different scale or whatever makes it work), disable them from showing up on the map but still include them in the legend. The important thing is you must turn auto-update off.

  • 1
    Thanks @she_weeds! I eventually used a combination of both options, i.e. duplicating the problematic layers with simpler icon construction destinated to legend only and editing the png map with an image editor such as Gimp to bring the last improvements to the legend. Hope that QGIS will evolve in making display options better! – wiltomap Sep 18 '17 at 6:28
  • Welcome! I love QGIS but the map composer is a bit behind everything else in functionality. QGIS 3 will be out around November so let's hope it will bring some longed-for improvements on that front. – she_weeds Sep 18 '17 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.