0

I am trying to install OTB-contrib package in Ubuntu Xenial. I did the following:

  • Download it and move it to /opt
  • Run the script
  • Added the following paths to my .bashrc file:
export PATH="$PATH:/opt/OTB-contrib-6.0.0-Linux64/bin"
export PYTHONPATH="$PYTHONPATH:/opt/OTB-contrib-6.0.0-Linux64/lib/python"
export OTB_APPLICATION_PATH="/opt/OTB-contrib-6.0.0-Linux64/lib/otb/applications"

After that, I have tried to run the applications from the command line, but I get a error message. For example:

ignacio@ignacio-Athena:~$ otbcli_OrthoRectification
/opt/OTB-contrib-6.0.0-Linux64/bin/otbcli: 34: .: Can't open /opt/OTB-contrib-6.0.0-Linux64/bin/../otbenv.profile

Does anybody know how to solve this?

  • sounds very permissions based, what user is trying to acces the app, does that user have access. Are you following any instructions, if not why move to opt? – nmtoken Sep 18 '17 at 19:17
  • I just checked and if I install it in my home directory it works like a charm. What do I need to do to make it available for all the users? – opengisapprendice Sep 18 '17 at 20:10
  • Agree that it is an issue related to files permissions. You need to check that users have read and execution access to OTB-contrib-6.0.0-Linux64 directory (and files inside it) – Manuel Grizonnet Sep 19 '17 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.