3

I am trying to print a map made in an earlier version of QGIS, but now the text annotations are not appearing in the print composer. "Draw map canvas items" is checked on. Am I missing something else perhaps? I've tried in both version 2.14 and 2.18 (running on a Mac with Sierra).

Here is the map in the main project window: enter image description here

Here is the map in the print composer: enter image description here

At this point I'm wondering if anyone else can confirm that this is just my problem and not a bug. Can anyone else on a Mac confirm that text annotations look normal in a print composer? They printed fine a year ago (the last time I worked in QGIS). I now have a new computer and downloaded the latest version of the software. I've tried creating entirely new projects to isolate the problem, but text annotations won't print in any of them.

  • Welcome ! Please add some more details (screenshots, qgs extracts, etc). For the moment it's quite hard to see what could go wrong. – gisnside Sep 19 '17 at 13:43
  • I'm not sure what "qgs extracts" are. How do I get those? – Schaeff Sep 19 '17 at 15:34
  • Thank you for the detail. It's good like that. For your info, QGS are the project xml file. Screenshots will be ok :) – gisnside Sep 19 '17 at 19:27
  • Nice map by the way ! – gisnside Sep 19 '17 at 19:36
  • If I remember correctly, map annotations are a fairly new addition to QGIS. Perhaps something has been changed in QGIS that makes map annotations created in older versions not compatible with new versions. You could test this idea by adding some new annotations and see if they show up in the print composer. If this is the problem, the solution would be either to submit a bug report and wait for a fix, or re-create all your annotations in recent version of QGIS. – csk Sep 22 '17 at 15:44
1

check "draw map canvas items" box in composer

enter image description here

  • Thank you. As I mentioned above, it is already checked. (I tried to screen shot that, but apparently I can only have two screenshots as a new person here.) – Schaeff Sep 19 '17 at 16:59
  • is the "fixed map position" box checked in the annotation properties? i unchecked it and checked it back and the annotation was gone for good in the composer – Elio Diaz Sep 19 '17 at 18:00
  • Each of the text annotations have "fixed map position" checked. I have not unchecked them. – Schaeff Sep 19 '17 at 19:02
  • reading all through the comments and answers here I can't find any difference but the Mac, I'll try to get my hands on one this week – Elio Diaz Sep 20 '17 at 17:00
0

It could maybe be related to the coordinate system. If you are using lat/long (EPSG4326 / WGS84), try using a local metric projected system and see what happens.

  • Thanks for the suggestion. I reprojected into NAD83, but text annotations still not appearing in the print composer. – Schaeff Sep 20 '17 at 15:32
0

QGIS 3 has appeared to have fixed this issue; test out your project file with the new version and make sure it's working now as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.