1

I am trying to obtain a clipping of a contour map into a polygon by using the command

Vector-> Geoprocessing tools -> Clip

in QGIS 2.18.13 freshly installed on Ubuntu 14.04. I run the command on a contour lines layer whose files are within a directory since it is a DXF file (to be imported to autocad) and a shapefile (a polygon basically)

But when I run the command I get the message:

"NameError: global name 'features' is not defined"

Is this error due to some coding glitch in the new release? What is the global name Features referring to?

  • Hi PolyGeo...I am not sure I understand why you edited my post. You took the word "regards" away. Why? I know it doens't add to my original question but I think showing respect and politeness towards the people who might read my question is important and makes this forum more human friendly. – Antonio Scotti Sep 20 '17 at 9:22
  • 1
    Politeness also comes in the form of meeting social expectations. Here in GIS SE, it is polite to honor the "no chit-chat" charter, and curate a question that is direct and to the point. As a question in a database of questions, introdutions, thanks, closings, and signatures all just waste space on the server. – Vince Sep 20 '17 at 10:58
  • Hi Vince, thanks for your opinion. So from what you write, saying "Regards" is considered chit-chat...I didn't know or even imagine that...For me social expectations also means 'wasting' a few bits for the sake of making a cold forum like this (like any other virtual communications spaces, for that matter) more human. Anyway I am grateful for the other edits since I understand the aims of making the questions more readily answerable. – Antonio Scotti Sep 20 '17 at 13:38
  • 1
    Have you tried converting the contours to shapefiles before attempting the clip? Might be a DXF issue. – underdark Sep 20 '17 at 17:32
  • Not sure how to do that, what's the way to do it? Within the .DXF directory there are 4 files and one of them is a .SHP file. On the other hand the layers panel just shows the name of the directory where this file is contained (and the directory name has the .DXF extension) – Antonio Scotti Sep 21 '17 at 10:40
1

This is a known bug in version 2.18.13 of QGIS. https://issues.qgis.org/issues/17248

0

are your contour lines shapefiles line type? If so, you need to convert to polygon to clip another polygon; you should also ensure projections are the same on both shapes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.