0

I have both arcgis online and arcgis portal organization accounts. I did all steps to create web appbuilder developer edition according to documents like this one : https://developers.arcgis.com/web-appbuilder/guide/getstarted.htm

I enter correctly both my Arcgis Online Url and App id, that i created in same arcgis online acount - contents. But i still get this error:

Error

Invalid redirect_uri

Error: 400

There is also another problem. When I type my portal Url, System doesnt accept it. I can only use my arcgis online account.(This problem is resolved. When I go to website with mozilla it doesn't accept my portal url, but with chrome it works. )

I tried different methods. But i always get this error. I also removed signinginfo.json file in /server everytime I fail entering website.

enter image description here

2 Answers 2

1

How do you have your redirects set up? In mine, I have the Data Source URL set to my computer's webappbuilder page as well as the Redirect URI's. I include both http and https in the redirects. This screenshot illustrates that. The first two redirects are to my computer (without the port number)

enter image description here

9
  • I had the same issue as OP and this answer was given to me by ESRI Support and it corrected my issue. be sure the app ID is the one under registration and not the one in the URL
    – NULL.Dude
    Commented Sep 20, 2017 at 13:02
  • @kenbuja I also have set up my redirects with both http and https versions. But I couldn't get what you mean with computer's web appbuilder page Commented Sep 20, 2017 at 13:22
  • @Geo.Dude I am pretty sure that i am using app id under registration. Commented Sep 20, 2017 at 13:26
  • Can you post an image of your settings page?
    – kenbuja
    Commented Sep 20, 2017 at 13:27
  • I added image on question. Commented Sep 20, 2017 at 13:40
0

I found out the solution. The problem was that I was using remote desktop. I did same steps in my computer and there was no error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.