2

I've been using MMQGIS geocoding with Google Maps as the geocoder for a little while now, never any issue. As of yesterday, have gotten a few strange issues. I was unable to geocode at all yesterday, as it was giving me an HTTP 503 error when trying to connect to the google api. I figured this was just a result of maintenance or whatnot, so I used the openstreetmap geocoder, which is unfortunately far less accurate.

I tried using the google geocoder today, and it's even stranger, it successfully geocodes some of my addresses, but usually quits before I get to 10 of them, saying that I've reached my limit for the day. Not only is this impossible, it's also said this on different amounts of addresses geolocated (I've had 0, 2, 6, 7, and 10 so far). Has anyone else been having this issue, or does anyone have any possible solutions?

  • 2
    So you have your own API key and you have not reached the limits developers.google.com/maps/documentation/geocoding/usage-limits? – user30184 Sep 20 '17 at 16:02
  • Just the standard through MMQGIS, nothing on top of that, no. The maximum I think I've EVER done in a day is around 500, I've never even come close to the 2,500 limit. – sousaman Sep 20 '17 at 16:04
  • if your IP is shared and it goes over 2500 (or too fast a request) - ISP's do this...not your router. – Mapperz Sep 20 '17 at 18:55
  • Also note that you can't create derivative works from that API - see ToS 10.4.c ii. developers.google.com/maps/terms#10-license-restrictions – BradHards Sep 21 '17 at 2:43
  • I've been having the same issue that sousaman mentioned while using MMQGIS. I tried to use the plugin from a different IP since I found out that Google calculates quotas for free use based on an IP "identification". Maybe this can be a solution for you? For me, it was not. Whatever IP I try to geocode from, I still get the same error within a few seconds. And it's not a matter of exceeded daily limit (2500 request) as sousaman said, because I do not share my quota with anyone else. I guess it must be a matter of speed of the requests. Is there a way you can change MMQGIS settings in order to d – Benedetta Oct 19 '17 at 14:05
3

you should get an API key of your own, as @user30184 suggested.

  • you'll still be restricted to certain volumes and rate limits, but they'll be YOUR limits, if you're careful :-)
  • you should be able to use the control panel to see how much of your quota is left.
  • you can pay to upgrade those quotas if you have lots to geocode

without an API key, the plugin uses this key-less endpoint

http://maps.googleapis.com/maps/api/geocode/xml?sensor=false&address=XXX

This is only really intended for demonstration purposes.

As @mapperz points out, this is limited by IP address. See this answer for more details. You might be sharing this quota with others, which would explain the outages.

You should be able to paste your API key into the dialog. If you don't see it, upgrade MMQGIS to the latest version in the plugin manager.

From a quick look at the code, it looks as if one call is made per row , but these are spaced out to a maximum of 2 calls/sec to avoid problems with rate limiting.

1

Are you using this model with MMQGIS just to obtain the address geocode or you have some additional workflow. If you are using it just to make the batch geocode conversion from address to latitude and longitude and you already have csv files ready, why don't you try this tool: CSV2GeoData at csv2geo.com. It will do the job of converting address to coordinates and only does live conversions and it is very precise. Disclaimer: I work for CSV2GeoData at https://csv2geo.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.