4

I have created a virtual machine using Osgeo-live 11 in Lubuntu and when I try to start the GeoServer or any other web services they start correctly but when I run it on web I get errors like in the picture below:

HTTP 503 service unavailable error

I have used this previous package of OSGeo live like 6, 8, 9 and everything was OK, in this release I don't why the web services don't work.

  • 1
    is that browser on the same machine geoserver is running and did you change the default port to 8082? if your answer is YES NO then try localhost:8080/geoserver/web – risail Sep 21 '17 at 13:13
  • They have configured the port to 8082 as default for this app, anyway i tried even in 8080 but with this port it says "Unable to connect", nothing exist in this port. – Shefqet LULJA Sep 21 '17 at 13:25
  • That does not answer the first question. Log onto the machine and make sure you are not blocking with a fw and that the service is running that error is an indicator it's not – risail Sep 21 '17 at 13:51
  • I didn't manually change anything after the installation, nothing should block the software, i don't even have any firewall or antivirus installed, its the untouched Osgeolive – Shefqet LULJA Sep 21 '17 at 13:57
  • What if you use http://localhost:8082/geoserver/web ? – nmtoken Sep 21 '17 at 18:52
2

You are being affected by this bug - for some reason the user user is not in the group users so GeoServer can't write to it's data directory. The fix is to run (once):

sudo adduser user users

and then log out and back in again.

-1

You can start GeoServer in Terminal with the command below

sudo /usr/local/bin/geoserver_start_admin.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.