I am trying to access a map service my organization publishes for our customers from QGIS. The service is hosted in ArcGIS for Server 10.5 and is secured.

QGIS allows me to set up a connection, but when I try to connect, I get "The query returned no layers." The same service, if i change it to not be secured, will connect and the layers are able to be added to the map.

Has anyone else tried accessing a secured ArcGIS Server map service from QGIS? Most questions I see seem to be connecting to open services.

  • did you make any progress here? I can add publis wfs services from AGOL, but not able to add WFS or WMS from our ArcGIS Portal to my own QGIS. I am attempting to pass creds using the same creds I use to log in to Portal
    – mike
    Commented Mar 19, 2018 at 22:01
  • I didn't, and we moved in a new direction so I am no longer looking at it.
    – tracy
    Commented Mar 21, 2018 at 12:02
  • I have the same issue, do you find a solution for this issue?
    – Majdoleen
    Commented Dec 28, 2018 at 15:46
  • I am also facing this issue. I set up proxy for esri secured layers accessing. but while trying to access the proxy url from qgis showing error. my url is sample.com/proxy/proxy.ashx?http://services5859.com/… error is sample.com/proxy/proxy.ashx?http://services5859.com/… bad request the reason is request attaching '&' instead of '?' after 'MapServer'. Any idea to solve this? Commented Sep 17, 2019 at 5:30

1 Answer 1


My team had this problem too. The issue is that ESRI uses token authentification for secure map services, and QGIS has no way to set up this token authentification.

We tried manually generating tokens (see https://enterprise.arcgis.com/en/server/10.3/administer/linux/acquiring-arcgis-tokens.htm) and adding the token key to the end of the map service URL eg. https://arcgis03.blabla.com:6666/arcgis/rest/services/BlablaCache/Nameofservice/MapServer?token=key

This did not work for a ArcGISMapServer connection in QGIS or for WMS/WMTS. It WOULD work for XYZ Tile eg. https://arcgis03.blabla.com:6666/arcgis/rest/services/blablaCache/Nameofservice/MapServer/WMTS/tile/1.0.0/Nameofservice/default/default028mm/{z}/{y}/{x}?token=key.

However XYZ Tile is limited to Web Mercator.

Since this was not practical for us, what we actually ended up doing is hosting a copy of the data on our private development server as well as the public secured service. I hope there is a better solution one day!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.